Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061724 - [engine] Redundant Commit Network Changes command is sent to host when cluster is changed
Summary: [engine] Redundant Commit Network Changes command is sent to host when cluste...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.4.0
Assignee: Moti Asayag
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 13:50 UTC by Gadi Ickowicz
Modified: 2014-08-22 01:42 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:28:53 UTC
oVirt Team: ---


Attachments (Terms of Use)
engine logs (deleted)
2014-02-05 13:50 UTC, Gadi Ickowicz
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24236 None None None Never

Description Gadi Ickowicz 2014-02-05 13:50:35 UTC
Created attachment 859665 [details]
engine logs

Description of problem:
Moving a host to maintenance and selecting a different datacenter, where both the previous DC's cluster and the new DC's cluster do not have labelled networks result in the host's network configuration being updated:

2014-02-05 15:08:38,263 INFO  [org.ovirt.engine.core.bll.ChangeVDSClusterCommand] (ajp--127.0.0.1-8702-10) [355f2fa] Running command: ChangeVDSClusterCommand internal: false. Entities affected :  ID: 3a31b558-70c2
-4e3b-bdae-20b0410dae75 Type: VDS,  ID: de8d037c-439a-41b0-b44a-a50569912245 Type: VdsGroups
2014-02-05 15:08:38,271 INFO  [org.ovirt.engine.core.vdsbroker.RemoveVdsVDSCommand] (ajp--127.0.0.1-8702-10) [355f2fa] START, RemoveVdsVDSCommand(HostName = gold-vdsc.qa.lab.tlv.redhat.com, HostId = 3a31b558-70c2-
4e3b-bdae-20b0410dae75), log id: 488488d6
2014-02-05 15:08:38,272 INFO  [org.ovirt.engine.core.vdsbroker.VdsManager] (ajp--127.0.0.1-8702-10) [355f2fa] vdsManager::disposing
2014-02-05 15:08:38,276 INFO  [org.ovirt.engine.core.vdsbroker.RemoveVdsVDSCommand] (ajp--127.0.0.1-8702-10) [355f2fa] FINISH, RemoveVdsVDSCommand, log id: 488488d6
2014-02-05 15:08:38,277 ERROR [org.ovirt.engine.core.vdsbroker.ResourceManager] (ajp--127.0.0.1-8702-10) [355f2fa] Cannot get vdsManager for vdsid=3a31b558-70c2-4e3b-bdae-20b0410dae75
2014-02-05 15:08:38,282 INFO  [org.ovirt.engine.core.vdsbroker.AddVdsVDSCommand] (ajp--127.0.0.1-8702-10) [355f2fa] START, AddVdsVDSCommand(HostName = gold-vdsc.qa.lab.tlv.redhat.com, HostId = 3a31b558-70c2-4e3b-b
dae-20b0410dae75), log id: 30f60348
2014-02-05 15:08:38,283 INFO  [org.ovirt.engine.core.vdsbroker.AddVdsVDSCommand] (ajp--127.0.0.1-8702-10) [355f2fa] AddVds - entered , starting logic to add VDS 3a31b558-70c2-4e3b-bdae-20b0410dae75
2014-02-05 15:08:38,285 INFO  [org.ovirt.engine.core.vdsbroker.AddVdsVDSCommand] (ajp--127.0.0.1-8702-10) [355f2fa] AddVds - VDS 3a31b558-70c2-4e3b-bdae-20b0410dae75 was added, will try to add it to the resource m
anager
2014-02-05 15:08:38,286 INFO  [org.ovirt.engine.core.vdsbroker.VdsManager] (ajp--127.0.0.1-8702-10) [355f2fa] Entered VdsManager constructor
2014-02-05 15:08:38,304 INFO  [org.ovirt.engine.core.vdsbroker.VdsManager] (ajp--127.0.0.1-8702-10) [355f2fa] Initialize vdsBroker (gold-vdsc.qa.lab.tlv.redhat.com,54,321)
2014-02-05 15:08:38,309 INFO  [org.ovirt.engine.core.vdsbroker.ResourceManager] (ajp--127.0.0.1-8702-10) [355f2fa] VDS 3a31b558-70c2-4e3b-bdae-20b0410dae75 was added to the Resource Manager
2014-02-05 15:08:38,310 INFO  [org.ovirt.engine.core.vdsbroker.AddVdsVDSCommand] (ajp--127.0.0.1-8702-10) [355f2fa] FINISH, AddVdsVDSCommand, log id: 30f60348
2014-02-05 15:08:38,315 INFO  [org.ovirt.engine.core.bll.AddVdsSpmIdCommand] (ajp--127.0.0.1-8702-10) [46fb84a8] Running command: AddVdsSpmIdCommand internal: true. Entities affected :  ID: 3a31b558-70c2-4e3b-bdae
-20b0410dae75 Type: VDS
2014-02-05 15:08:38,325 INFO  [org.ovirt.engine.core.bll.AddVdsSpmIdCommand] (ajp--127.0.0.1-8702-10) [46fb84a8] Lock freed to object EngineLock [exclusiveLocks= key: 947bb734-1050-4926-8a3a-03406ad80b1e value: RE
GISTER_VDS
, sharedLocks= ]
2014-02-05 15:08:38,345 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-10) [46fb84a8] Correlation ID: 355f2fa, Call Stack: null, Custom Event ID: -1, Message: Hos
t gold-vdsc.qa.lab.tlv.redhat.com configuration was updated by admin.
2014-02-05 15:08:38,350 INFO  [org.ovirt.engine.core.bll.network.host.PersistentSetupNetworksCommand] (org.ovirt.thread.pool-6-thread-28) [70f3d8c6] Running command: PersistentSetupNetworksCommand internal: true. 
Entities affected :  ID: 3a31b558-70c2-4e3b-bdae-20b0410dae75 Type: VDS
2014-02-05 15:08:38,380 INFO  [org.ovirt.engine.core.bll.network.host.SetupNetworksCommand] (org.ovirt.thread.pool-6-thread-28) [70f3d8c6] Running command: SetupNetworksCommand internal: true. Entities affected : 
 ID: 3a31b558-70c2-4e3b-bdae-20b0410dae75 Type: VDS
2014-02-05 15:08:38,388 INFO  [org.ovirt.engine.core.bll.network.host.CommitNetworkChangesCommand] (org.ovirt.thread.pool-6-thread-28) [61c9516c] Running command: CommitNetworkChangesCommand internal: true. Entiti
es affected :  ID: 3a31b558-70c2-4e3b-bdae-20b0410dae75 Type: VDS
2014-02-05 15:08:38,393 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetSafeNetworkConfigVDSCommand] (org.ovirt.thread.pool-6-thread-28) [61c9516c] START, SetSafeNetworkConfigVDSCommand(HostName = gold-vdsc.qa
.lab.tlv.redhat.com, HostId = 3a31b558-70c2-4e3b-bdae-20b0410dae75), log id: 310df495
2014-02-05 15:08:38,424 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (ajp--127.0.0.1-8702-9) Unable to get value of property: vdsName for class org.ovirt.engine.core.common.businessentities.VdsS
tatic
2014-02-05 15:08:38,425 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (ajp--127.0.0.1-8702-9) Unable to get value of property: vdsName for class org.ovirt.engine.core.common.businessentities.VdsS
tatic
2014-02-05 15:08:38,433 INFO  [org.ovirt.engine.core.bll.UpdateVdsCommand] (ajp--127.0.0.1-8702-9) [4586963f] Running command: UpdateVdsCommand internal: false. Entities affected :  ID: 3a31b558-70c2-4e3b-bdae-20b0410dae75 Type: VDS
2014-02-05 15:08:38,444 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (ajp--127.0.0.1-8702-9) Unable to get value of property: vdsName for class org.ovirt.engine.core.common.businessentities.VdsStatic
2014-02-05 15:08:38,445 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (ajp--127.0.0.1-8702-9) Unable to get value of property: vdsName for class org.ovirt.engine.core.common.businessentities.VdsStatic
2014-02-05 15:08:38,460 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-9) [4586963f] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Failed to verify Power Management configuration for Host gold-vdsc.qa.lab.tlv.redhat.com.
2014-02-05 15:08:38,467 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-9) [4586963f] Correlation ID: 4586963f, Call Stack: null, Custom Event ID: -1, Message: Host gold-vdsc.qa.lab.tlv.redhat.com configuration was updated by admin.
2014-02-05 15:08:38,750 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetSafeNetworkConfigVDSCommand] (org.ovirt.thread.pool-6-thread-28) [61c9516c] FINISH, SetSafeNetworkConfigVDSCommand, log id: 310df495
2014-02-05 15:08:38,756 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-6-thread-28) [61c9516c] Correlation ID: 61c9516c, Call Stack: null, Custom Event ID: -1, Message: Network changes were saved on host gold-vdsc.qa.lab.tlv.redhat.com
2014-02-05 15:08:40,782 INFO  [org.ovirt.engine.core.bll.ActivateVdsCommand] (ajp--127.0.0.1-8702-5) [5f40a3be] Lock Acquired to object EngineLock [exclusiveLocks= key: 3a31b558-70c2-4e3b-bdae-20b0410dae75 value: VDS
, sharedLocks= ]


Version-Release number of selected component (if applicable):
100% 

How reproducible:


Steps to Reproduce:
2 DC's, 1 cluster each. All network settings default (no labelled networks)
1. Move host to maintenance
2. Edit host -> move host to other DC

Actual results:
Looking at the logs, host's network settings are updated

Expected results:
Host's network settings should not be updated when there are no labelled networks

Additional info:

Comment 1 Gadi Ickowicz 2014-02-05 14:00:48 UTC
ovirt-engine version:
ovirt-engine-3.4.0-0.5.beta1.el6.noarch

Comment 2 Moti Asayag 2014-02-05 14:22:40 UTC
Having a deeper look at the logs reveals no setup networks request was sent to the host from the engine.

The failure is in the CommitNetworkChanges command which follows the SetupNetworks command.

This result in a failure since the host is not reachable.

The relevant piece of log is: 

2014-02-05 14:19:32,903 INFO  [org.ovirt.engine.core.bll.network.host.PersistentSetupNetworksCommand] (org.ovirt.thread.pool-6-thread-26) [66425f72] Running command: PersistentSetupNetworksCommand internal: true. Entities affected :  ID: 572277f7-a894-4526-9686-efcfbc9c6b86 Type: VDS
2014-02-05 14:19:32,954 INFO  [org.ovirt.engine.core.bll.network.host.SetupNetworksCommand] (org.ovirt.thread.pool-6-thread-26) [66425f72] Running command: SetupNetworksCommand internal: true. Entities affected :  ID: 572277f7-a894-4526-9686-efcfbc9c6b86 Type: VDS
2014-02-05 14:19:32,967 INFO  [org.ovirt.engine.core.bll.network.host.CommitNetworkChangesCommand] (org.ovirt.thread.pool-6-thread-26) [7cb98534] Running command: CommitNetworkChangesCommand internal: true. Entities affected :  ID: 572277f7-a894-4526-9686-efcfbc9c6b86 Type: VDS
2014-02-05 14:19:32,976 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetSafeNetworkConfigVDSCommand] (org.ovirt.thread.pool-6-thread-26) [7cb98534] START, SetSafeNetworkConfigVDSCommand(HostName = gold-vdsd.qa.lab.tlv.redhat.com, HostId = 572277f7-a894-4526-9686-efcfbc9c6b86), log id: 7ad0ed08
2014-02-05 14:19:34,995 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SetSafeNetworkConfigVDSCommand] (org.ovirt.thread.pool-6-thread-26) [7cb98534] Command SetSafeNetworkConfigVDSCommand(HostName = gold-vdsd.qa.lab.tlv.redhat.com, HostId = 572277f7-a894-4526-9686-efcfbc9c6b86) execution failed. Exception: VDSNetworkException: java.net.SocketTimeoutException: connect timed out
2014-02-05 14:19:34,997 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetSafeNetworkConfigVDSCommand] (org.ovirt.thread.pool-6-thread-26) [7cb98534] FINISH, SetSafeNetworkConfigVDSCommand, log id: 7ad0ed08
2014-02-05 14:19:34,998 ERROR [org.ovirt.engine.core.bll.network.host.CommitNetworkChangesCommand] (org.ovirt.thread.pool-6-thread-26) [7cb98534] Command org.ovirt.engine.core.bll.network.host.CommitNetworkChangesCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSNetworkException: java.net.SocketTimeoutException: connect timed out (Failed with error VDS_NETWORK_ERROR and code 5022)
2014-02-05 14:19:35,002 ERROR [org.ovirt.engine.core.bll.network.host.CommitNetworkChangesCommand] (org.ovirt.thread.pool-6-thread-26) [7cb98534] Transaction rolled-back for command: org.ovirt.engine.core.bll.network.host.CommitNetworkChangesCommand.

The resolution of this bug should be not to send commit network changes command - if no changes were applied to the host.

Comment 3 Sandro Bonazzola 2014-02-19 12:26:18 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 4 Martin Pavlik 2014-02-27 15:58:42 UTC
verified on ovirt-3.4.0-beta3

Comment 5 Sandro Bonazzola 2014-03-31 12:28:53 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.