Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061721 - Unable to create Orgs due to SSL issues with tomcat6
Summary: Unable to create Orgs due to SSL issues with tomcat6
Keywords:
Status: CLOSED DUPLICATE of bug 1010111
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 13:49 UTC by Kedar Bidarkar
Modified: 2014-06-19 19:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-05 17:14:15 UTC


Attachments (Terms of Use)

Description Kedar Bidarkar 2014-02-05 13:49:37 UTC
Description of problem:

After running katello-installer for sat6-mdp3 we get the below error while creating orgs.

OpenSSL::SSL::SSLError
SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: tlsv1 alert internal error
app/controllers/concerns/foreman/controller/taxonomies_controller.rb:47:in `create'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call' 


Version-Release number of selected component (if applicable):
http://satellite6.lab.eng.rdu2.redhat.com/devel/candidate-trees/Satellite/Satellite-6.0.3-RHEL-6-20140204.0/


How reproducible:
Upon creating Organizations.

Steps to Reproduce:
1.
2.
3.

Actual results:
Fails to create an Org with above mentioned error,
solution provided in Additionla info section.

Expected results:
Should succeed in creation of Orgs.

Additional info:

Found a temporary solution.

a) remove all ciphers from /etc/tomcat6/server.xml

and added just ciphers="SSL_RSA_WITH_RC4_128_SHA"

b) restart tomcat6 server

This is could be a dirty workaround please suggest appropriate approach.

Comment 4 Og Maciel 2014-02-05 17:12:55 UTC
The presence of Java 1.7 may be the culprit. mmccune removed it and things just worked.

Comment 5 Mike McCune 2014-02-05 17:14:15 UTC
see 1010111, this is a dupe.

*** This bug has been marked as a duplicate of bug 1010111 ***


Note You need to log in before you can comment on or make changes to this bug.