Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061720 - Categories are empty in gpk-application, unless you manually refresh metadata. Some categories are still empty then.
Summary: Categories are empty in gpk-application, unless you manually refresh metadata...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 19
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 13:49 UTC by Kevin L. Mitchell
Modified: 2014-06-30 18:42 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 822509
Environment:
Last Closed: 2014-06-30 18:42:50 UTC


Attachments (Terms of Use)

Description Kevin L. Mitchell 2014-02-05 13:49:32 UTC
+++ This bug was initially created as a clone of Bug #822509 +++

Description of problem:
If I run gpk-application and click on any category, nothing is shown, it's empty. On F16 it used to display all the packages that were part of that category.

Search works OK, just category browsing is broken.

Version-Release number of selected component (if applicable):
PackageKit-0.7.4-2.fc17.i686
PackageKit-command-not-found-0.7.4-2.fc17.i686
PackageKit-device-rebind-0.7.4-2.fc17.i686
PackageKit-glib-0.7.4-2.fc17.i686
PackageKit-gstreamer-plugin-0.7.4-2.fc17.i686
PackageKit-gtk3-module-0.7.4-2.fc17.i686
PackageKit-yum-0.7.4-2.fc17.i686
PackageKit-yum-plugin-0.7.4-2.fc17.i686

--- Additional comment from Kamil Páral on 2012-05-17 10:57:19 EDT ---

This is a clean F17 RC1 i386 installation from PXE, default desktop. I can reproduce that also after reboot. But my two colleagues don't have any problems and category browsing works (they have x86_64). Also it works in my VM (i686), but that is not a clean RC1 install, but upgraded system.

I don't see anything in /var/log/messages.

When clicking on a category pkmon outputs:

Transactions:
 1	/43_bdadbbaa_data
/43_bdadbbaa_data	percentage   -1
/43_bdadbbaa_data	role         search-group
/43_bdadbbaa_data	status       finished
/43_bdadbbaa_data	exit code: unknown

--- Additional comment from Tim Flink on 2012-05-17 11:37:20 EDT ---

I saw the same thing on a fresh x86_64 install of RC1 - if you click on 'refresh package lists' under the system menu, everything gets populated.

--- Additional comment from Kamil Páral on 2012-05-17 17:04:50 EDT ---

I left the computer running for a few hours and after I returned everything worked. I did not run "refresh package lists", it just fixed itself. So I assume there is some problem in yum caching.

I installed a clean RC1 into VM, but I couldn't reproduce it, category browsing worked out of the box. It's erratic.

--- Additional comment from G.Wolfe Woodbury on 2013-01-07 09:28:16 EST ---

Fresh install of Final-RC1 in VBox guest.
gpk-applicaion will NOT brows the "desktop" packages. Refresh package lists does NOT resolve the issue.  It will successfully browse some categories, just not the ones that have been adjusted for use with anaconda (installer).

--- Additional comment from Kamil Páral on 2013-01-07 13:30:17 EST ---

I can confirm that clean installation of F18 RC1 presents empty categories in gpk-application. After refreshing metadata I see packages in all categories except "* desktop".

--- Additional comment from Radek Vokal on 2013-11-28 09:29:16 EST ---



--- Additional comment from Kevin L. Mitchell on 2013-12-05 18:45:52 EST ---

This also happens in F19; refreshing package lists does appear to (temporarily) correct the issue.

--- Additional comment from Fedora End Of Life on 2013-12-21 03:36:22 EST ---

This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

--- Additional comment from Kevin L. Mitchell on 2013-12-21 09:18:11 EST ---

This bug is confirmed present in Fedora 19.

--- Additional comment from Fedora End Of Life on 2014-02-05 06:58:11 EST ---

Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

--- Additional comment from Kevin L. Mitchell on 2014-02-05 08:46:47 EST ---

I would re-open this bug if I could, because *I have confirmed that it is present in Fedora 19*, as mentioned in my comment from 2013-12-21.

Comment 1 G.Wolfe Woodbury 2014-06-30 18:42:50 UTC
Obsolete, fixed in 20
closing


Note You need to log in before you can comment on or make changes to this bug.