Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061718 - InternalServerError while selecting a existing activation key
Summary: InternalServerError while selecting a existing activation key
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 13:44 UTC by Sachin Ghai
Modified: 2014-07-02 14:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:04:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
error on selecting activation key from left pane (deleted)
2014-02-05 13:44 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2014-02-05 13:44:04 UTC
Created attachment 859651 [details]
error on selecting activation key from left pane

Description of problem:
Looks like a rendering issue when we select an existing activation key, UI throws error:

Error

There was an error retrieving that row:Internal Server Error


Version-Release number of selected component (if applicable):
foreman-proxy-1.5.1-1.el6sat.noarch
foreman-1.5.0.1-1.noarch
rubygem-foreman_api-0.1.11-2.el6sat.noarch
rubygem-hammer_cli_foreman-0.0.18-1.el6sat.noarch
foreman-postgresql-1.5.0.1-1.noarch
foreman-selinux-1.3.0-1.el6sat.noarch
dell-per810-03.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
dell-per810-03.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
[root@dell-per810-03 ~]# rpm -qa | grep katello
rubygem-hammer_cli_katello-0.0.2-4.el6sat.noarch
katello-1.5.0-16.el6sat.noarch
katello-certs-tools-1.5.2-1.el6sat.noarch
rubygem-katello_api-0.0.3-3.el6sat.noarch
katello-installer-0.0.20-1.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-katello-1.5.0-13.el6sat.noarch

Satellite6 MDP3 compose1  
How reproducible:
always

Steps to Reproduce:
1. Create an activation key
2. Select it from left pane
3.

Actual results:
Error

There was an error retrieving that row:Internal Server Error


Expected results:
on selection, the right pane should be opened up with name and details 

Additional info:

Comment 1 RHEL Product and Program Management 2014-02-05 16:12:14 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Tom McKay 2014-04-08 16:30:02 UTC
Working for some time in master

Comment 4 Corey Welton 2014-04-14 20:52:56 UTC
This appears to work now in Satellite-6.0.3-RHEL-6-20140404.0

Comment 5 Bryan Kearney 2014-07-02 14:04:57 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.