Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061695 - Problem with hypervisor registration using TUI
Summary: Problem with hypervisor registration using TUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: 1065425 1073049 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-02-05 13:02 UTC by Tomas Bily
Modified: 2018-12-05 17:13 UTC (History)
19 users (show)

Fixed In Version: ovirt-node-3.0.1-18.el6.7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:51:25 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description Tomas Bily 2014-02-05 13:02:41 UTC
Description of problem:
Registration to Satellite is not working in Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140112.0.el6) using TUI.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140112.0.el6)

How reproducible:
100%

Steps to Reproduce:
1.install a new hypervisor
2. Using TUI -  RHN Registration, fill in the username, password, choose Satellite, fill in the url and confirm.
3. Error is presented : An error occurred while applying the changes: Error registering to RHN account

Actual results:
Error message about registration issue

Expected results:
Successful registration 

Additional info:
Error message in ovirt-node:

014-01-26 20:50:54,016      ERROR Failed to call: ['/usr/sbin/rhnreg_ks', '--username', 'qsgarabiboh', '--password', 'XXXXXXX', '--profilename', 'bl460-275 - RHEV-H', '--novirtinfo', '--norhnsd', '--nopackages', '--force']
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt/node/setup/rhn/rhn_model.py", line 188, in commit
  File "/usr/lib64/python2.6/subprocess.py", line 505, in check_call
CalledProcessError: Command '['/usr/sbin/rhnreg_ks', '--username', 'qsgarabiboh', '--password', u'XXXXXXXX', '--profilename', 'bl460-275 - RHEV-H', '--novirtinfo', '--norhnsd', '--nopackages', '--force']' returned non-zero exit status 1
2014-01-26 20:50:54,020       INFO Captured nothing
2014-01-26 20:50:54,022       INFO An exception during the transaction: Error registering to RHN account
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt/node/ui/__init__.py", line 945, in __run_transaction
  File "/usr/lib/python2.6/site-packages/ovirt/node/plugins.py", line 234, in dry_or
  File "/usr/lib/python2.6/site-packages/ovirt/node/ui/__init__.py", line 945, in <lambda>
  File "/usr/lib/python2.6/site-packages/ovirt/node/setup/rhn/rhn_model.py", line 199, in commit
RuntimeError: Error registering to RHN account


Running the rhnreg_ks command manually works as expected and the system gets registred

Comment 1 Fabian Deutsch 2014-02-05 17:15:16 UTC
Hey Tomas,

could you please ask the customer to provide

/etc/default/ovirt

and the rhnreg_ks command he ran manually.

Comment 3 Tomas Bily 2014-02-06 08:11:03 UTC
Hello Fabian,

the rhnreg_ks command ran manually is as follows:

/usr/sbin/rhnreg_ks --username=qsgarabiboh --password=XXXXXX --profilename="bl460-275 - RHEV-H" --serverUrl=https://rhn.cezdata.corp/XMLRPC --novirtinfo --norhnsd --nopackages --force -vvv --sslCACert=RHN

Comment 4 Tomas Bily 2014-02-06 13:05:05 UTC
Fabian,

as requested, this is the /etc/default/ovirt content:

[root@bl460-275 ~]# cat /etc/default/ovirt
MANAGED_BY="oVirt Engine http://rhevm.cezdata.corp:8443"
MANAGED_IFNAMES="rhevm"
OVIRT_BOND_NAME="bond0"
OVIRT_BOND_OPTIONS="mode=1 miimon=100"
OVIRT_BOND_SLAVES="eth1,eth0"
OVIRT_BOOTIF="bond0"
OVIRT_BOOTPARAMS="RD_NO_LVM crashkernel=128M elevator=deadline quiet max_loop=256 rhgb rd_NO_LUKS rd_NO_MD rd_NO_DM"
OVIRT_CONFIG_VERSION="3.0.1"
OVIRT_DNS="172.24.255.10,172.24.254.10"
OVIRT_FIRSTBOOT="0"
OVIRT_HOSTNAME="bl460-275.cezdata.corp"
OVIRT_INIT=""
OVIRT_INSTALL=""
OVIRT_IP_ADDRESS="172.24.8.215"
OVIRT_IP_GATEWAY="172.24.8.1"
OVIRT_IP_NETMASK="255.255.255.0"
OVIRT_ISCSI_NODE_NAME="iqn.1994-05.com.redhat:e559a159321b"
OVIRT_KEYBOARD_LAYOUT="us"
OVIRT_LOGROTATE_MAX_SIZE="1024"
OVIRT_MANAGEMENT_CERTIFICATE="/etc/pki/vdsm/certs/engine_web_ca.pem"
OVIRT_MANAGEMENT_PORT="8443"
OVIRT_MANAGEMENT_SERVER="rhevm.cezdata.corp"
OVIRT_NTP="ntpg.cezdata.corp,ntpt.cezdata.corp"
OVIRT_RHN_ACTIVATIONKEY=""
OVIRT_RHN_CA_CERT="http://rhn.cezdata.corp/pub/RHN"
OVIRT_RHN_ORG=""
OVIRT_RHN_PROFILE="bl460-275 - RHEV-H"
OVIRT_RHN_PROXYUSER=""
OVIRT_RHN_TYPE="satellite"
OVIRT_RHN_URL="https://rhn.cezdata.corp/XMLRPC"
OVIRT_RHN_USERNAME="qsgarabiboh"
OVIRT_SNMP_ENABLED="1"
OVIRT_SSH_PWAUTH="yes"
OVIRT_STANDALONE="1"
OVIRT_UPGRADE=""
OVIRT_USE_STRONG_RNG=""

Comment 5 Guohua Ouyang 2014-02-07 06:23:48 UTC
1. QE cannot reproduce the issue on rhevh 6.5-20140112.0.el6, register RHN satellite successfully.
2. Also tested the jenkins auto1032 build, it register to RHN satellite successfully.

Comment 7 Guohua Ouyang 2014-02-07 06:47:06 UTC
I guess http://rhn.cezdata.corp/pub/RHN should be https://rhn.cezdata.corp/pub/RHN

Comment 8 Tomas Bily 2014-02-11 09:37:34 UTC
Hello,

customer claims the certificate is correct.

Is it possible that the issue is caused by missing Satellite server URL in rhnreg_ks call? As Fabian mentioned (cmnt #2):
Customer used custom satellite url, but url does not appear in rhnreg_ks call.

Comment 9 Guohua Ouyang 2014-02-11 09:52:55 UTC
oh, I believe the problem is that serverUrl should be https://rhn.cezdata.corp but not https://rhn.cezdata.corp/XMLRPC

Please ask customer do not add XMLPRC to the url and give it a try.

Comment 10 Guohua Ouyang 2014-02-11 10:06:52 UTC
any(In reply to Ouyang guohua from comment #9)
> oh, I believe the problem is that serverUrl should be
> https://rhn.cezdata.corp but not https://rhn.cezdata.corp/XMLRPC
> 
> Please ask customer do not add XMLPRC to the url and give it a try.

anyway, https://rhn.cezdata.corp/XMLRPC should be acceptable, after read bug 782893, this is a regression isssue.

Comment 26 Yaning Wang 2014-12-10 07:35:59 UTC
Tested on

RHEV-H 6.6-20141119.0.el6ev

Test steps:

1. install rhevh
2. register to RHN in TUI with username:password
3. registration is successful
4. register to Satellite with url / ca
5. registration is successful

Comment 28 errata-xmlrpc 2015-02-11 20:51:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.