Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061650 - ekiga-config-tool and ekiga-helper are missing man pages [NEEDINFO]
Summary: ekiga-config-tool and ekiga-helper are missing man pages
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ekiga
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Benjamin Otte
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 10:32 UTC by Martin Simon
Modified: 2016-09-20 02:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-21 05:49:06 UTC
Target Upstream Version:
msimon: needinfo? (mclasen)


Attachments (Terms of Use)

Description Martin Simon 2014-02-05 10:32:09 UTC
Description of problem:
ekiga-config-tool and ekiga-helper are missing man pages. As they are binaries under /usr/bin, they should have man page. Otherwise, there should not be under /usr/bin if they are not supposed to be run by user.

Version-Release number of selected component (if applicable):
ekiga-4.0.1-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. download http://download.eng.brq.redhat.com/archive/RHELManPageCheck/man-page-day.sh
2. execute ./man-page-day.sh ekiga


Actual results:
ekiga-4.0.1-4.el7.x86_64

checking whether binary files have man pages:

[ OK ] binary /usr/bin/ekiga has man page /usr/share/man/man1/ekiga.1.gz
[ Error ] binary /usr/bin/ekiga-config-tool has no man page!
[ Error ] binary /usr/bin/ekiga-helper has no man page!

checking whether config files have man pages:

[ Warn ] config file /etc/gconf/schemas/ekiga.schemas has no man page! Check it's content for proper documentation

checking for unused man pages:

[ OK ] no man pages left

now checking individual man pages:

checking /usr/share/man/man1/ekiga.1.gz:
[ OK ] man page parsing with lexgrog succeeded
[ OK ] man page doesn't contain any repeated word

Summary: 4x OK, 1 warnings, 2 errors

Expected results:
no error, ekiga-config-tool and ekiga-helper should have man page or not to be in /usr/bin


Additional info:

Comment 1 Martin Simon 2014-02-24 15:50:16 UTC
What's the reason for closing it? ekiga-config-tool and ekiga-helper are in in standard path (/usr/bin) and are accessible to every user, so they should have man pages. If they are not supposed to be run by ordinary user, they shouldn't be in PATH and then don't need to have man pages. Or am I wrong?


Note You need to log in before you can comment on or make changes to this bug.