Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061628 - bind on doesn't work with null backend
Summary: bind on doesn't work with null backend
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: David Spurek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 09:22 UTC by David Spurek
Modified: 2015-03-02 05:28 UTC (History)
3 users (show)

Fixed In Version: openldap-2.4.39-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:58:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1426 normal SHIPPED_LIVE openldap bug fix and enhancement update 2014-10-14 01:06:20 UTC

Description David Spurek 2014-02-05 09:22:52 UTC
Description of problem:
bind on doesn't work with null backend

Version-Release number of selected component (if applicable):
openldap-2.4.23-32.el6_4.1.

How reproducible:
alwayus

Steps to Reproduce:
1.setup ldap with null backend:
add:
database  null
suffix "cn=Nothing"
bind on

2.Run ldapsearch -D "uid=none,cn=Nothing" -w testing -b 'cn=Nothing'
3.

Actual results:
ldap_bind: Invalid credentials (49)

Expected results:
return success with return code 0

Additional info:

Comment 6 errata-xmlrpc 2014-10-14 04:58:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1426.html


Note You need to log in before you can comment on or make changes to this bug.