Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061585 - Remove-brick: File permission (setuid) changes after migration of the file [NEEDINFO]
Summary: Remove-brick: File permission (setuid) changes after migration of the file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs
Version: 2.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: RHGS 3.0.3
Assignee: vsomyaju
QA Contact: Amit Chaurasia
URL:
Whiteboard:
Depends On:
Blocks: 1086228 1162573 1162694 1168549
TreeView+ depends on / blocked
 
Reported: 2014-02-05 07:02 UTC by shylesh
Modified: 2015-10-28 00:10 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.6.0.33-1
Doc Type: Bug Fix
Doc Text:
Previously, if the setuid bit of a file was set and if the file was migrated after a remove-brick operation, after the file migration, the setuid bit did not exist. With this fix, changes are made to ensure that the file permissions retain the setuid bit even after file migration.
Clone Of:
: 1086228 1168549 (view as bug list)
Environment:
Last Closed: 2015-01-15 13:36:59 UTC
sharne: needinfo? (vsomyaju)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0038 normal SHIPPED_LIVE Red Hat Storage 3.0 enhancement and bug fix update #3 2015-01-15 18:35:28 UTC

Description shylesh 2014-02-05 07:02:29 UTC
Description of problem:
If a file has setuid bit set and if it is migrated through remove-brick then setuid bit disappears after migration.

Version-Release number of selected component (if applicable):

3.4.0.59rhs-1.el6_4.x86_64
How reproducible:
always

Steps to Reproduce:
1.creted a 6x2  distributed-replicate volume
2. added a new user test and created some files on the mount point as test user
3. set the sticky bit and setuid bit
chmod +t <file> & chmod +s <file>
4. permission becomes 
-rwSrwSr-T
5. Now remove one of the pair using remove-brick command
gluster volume remove-brick <vol> <brick> start 
6. once the migration is complete commit it 
7. check the permissions on the mount point

Actual results:

permission of the file got changed to  -rw-rwSr-T.

so setuid bit is missing for user

 
Additional info:

[root@rhs-client4 ~]# gluster v info
 
Volume Name: dist-rep
Type: Distributed-Replicate
Volume ID: fccb1682-2a43-4925-a030-d303aaa43352
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: rhs-client4.lab.eng.blr.redhat.com:/home/dist-rep0
Brick2: rhs-client9.lab.eng.blr.redhat.com:/home/dist-rep1
Brick3: rhs-client4.lab.eng.blr.redhat.com:/home/dist-rep4
Brick4: rhs-client9.lab.eng.blr.redhat.com:/home/dist-rep5

Decommissioned bricks
----------------------
rhs-client4.lab.eng.blr.redhat.com:/home/dist-rep6 rhs-client9.lab.eng.blr.redhat.com:/home/dist-rep7 


cluster info
---------------
rhs-client9.lab.eng.blr.redhat.com
rhs-client40.lab.eng.blr.redhat.com
rhs-client4.lab.eng.blr.redhat.com

client
------
10.70.35.26

mount type nfs
mount point  10.70.35.26:/nfs

attached the sosreports



mount was on

Comment 5 Amit Chaurasia 2014-11-25 10:04:37 UTC
Followed the repro steps and checked the permissions of the file after the migration. The permissions are intact. Closing the bug.

Comment 6 Shalaka 2015-01-09 10:54:57 UTC
Please review and sign-off edited doc text.

Comment 8 errata-xmlrpc 2015-01-15 13:36:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0038.html


Note You need to log in before you can comment on or make changes to this bug.