Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061457 - python27 meta package should include LICENSE, README and python27 man page files
Summary: python27 meta package should include LICENSE, README and python27 man page files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: python
Version: python27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 1.1
Assignee: Bohuslav "Slavek" Kabrda
QA Contact: Branislav Náter
URL:
Whiteboard:
Depends On:
Blocks: 1061439 1082031
TreeView+ depends on / blocked
 
Reported: 2014-02-04 21:05 UTC by Honza Horak
Modified: 2014-06-04 07:26 UTC (History)
3 users (show)

Fixed In Version: python27-1.1-15.el6 python27-1.1-17.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-04 07:26:48 UTC


Attachments (Terms of Use)
README template with some grammar corrections (deleted)
2014-02-12 15:21 UTC, Honza Horak
no flags Details
README template with some grammar corrections (deleted)
2014-02-12 15:55 UTC, Honza Horak
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0610 normal SHIPPED_LIVE python27 bug fix and enhancement update 2014-06-04 11:06:18 UTC

Description Honza Horak 2014-02-04 21:05:05 UTC
Meta package of python27 software collection should include the following files:
* LICENSE file with proper license text for meta package's license
* README file with python27 collection description, usage and examples
* python27.7 man page, which is located under /opt/rh and contains information related to python27 collection -- description, usage and examples

The tracking bug 1061439 proposes a generic way how to use RPM macros in the README file, how such file can be structured and also cointains an example how to generate the man page from such a README file. See bug 1061439 for more information.

Proposed content of the README file, generated for python27 collection (please check and change things specific for python27 collection), where RPM macros are used (see tracking bug 1061439 how to expand them in the spec file):
------------------------------------------
Package %{scl_name} provides Python programming language delivered using Software
Collections concept. For more information about Software Collections
concept, read scl(1). By installing %{scl_name} collection, you will get
the minimum working set of packages to have working Python programming language.

Usage: scl enable %{scl} 'python'

Software Collections concept allows to build and execute applications
which are not located in the filesystem root hierarchy but are present
in an alternative location, which is %{scl_prefix}
in case of %{scl_name} collection.

Python is an interpreted, interactive, object-oriented programming
language often compared to Tcl, Perl, Scheme or Java. Python includes
modules, classes, exceptions, very high level dynamic data types and
dynamic typing. Python supports interfaces to many system calls and
libraries, as well as to various windowing systems (X11, Motif, Tk,
Mac and MFC).

When working with %{scl_name} collection, use scl utility (see scl(1)
for usage) to enable scl environment properly.

Configuration for the %{scl_name} software collection is located under %{_sysconfdir}.

Examples:
scl enable %{scl_name} 'command --arg'
  Run a specific command with argument --arg within %{scl_name} software collections
  environment.

scl enable %{scl_name} 'python'
  Run python from %{scl_name} software collection.

scl enable %{scl_name} bash
  Run interactive shell where %{scl_name} software collection is enabled.

scl enable %{scl_name} 'man python'
  Show man pages for python command, which is part of the %{scl_name} software
  collection.

Comment 2 Honza Horak 2014-02-10 20:25:49 UTC
FYI, tracking bug #1061439 now contains adjusted and a bit simplified patch to generate man page from the README file attached here.

After discussion, it seems better to generate the man page in %build section, provide meaningful version in the man page and include notice about reporting bugs.

It was also agreed that the version of meta package should correspond with version of the RHSCL.

Comment 3 Honza Horak 2014-02-12 15:21:52 UTC
Created attachment 862376 [details]
README template with some grammar corrections

There were some grammar issues in the original README template. This is a grammar correction of the general README template from Petr Kovar:
http://etherpad.corp.redhat.com/XYVrBLTLow

And README template for python27 is attached.

Comment 4 Honza Horak 2014-02-12 15:55:07 UTC
Created attachment 862400 [details]
README template with some grammar corrections

Few grammar fixes more.

Comment 7 Branislav Náter 2014-04-11 11:51:48 UTC
Verified on python27-1.1-16.el6.x86_64 and python27-1.1-19.el7.x86_64 using automated test:

/CoreOS/scl-utils/Regression/general-Include-License-Readme-and-man-page

and manually:

# rpm -ql python27-runtime | egrep 'LIC|READ|man7/py'
/opt/rh/python27/root/usr/share/doc/python27-runtime-1.1/LICENSE
/opt/rh/python27/root/usr/share/doc/python27-runtime-1.1/README
/opt/rh/python27/root/usr/share/man/man7/python27.7.gz

Comment 8 errata-xmlrpc 2014-06-04 07:26:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0610.html


Note You need to log in before you can comment on or make changes to this bug.