Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061372 (packstack_vcenter) - [RFE]: Add PackStack support for vCenter driver. [NEEDINFO]
Summary: [RFE]: Add PackStack support for vCenter driver.
Keywords:
Status: CLOSED ERRATA
Alias: packstack_vcenter
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z4
: 4.0
Assignee: Francesco Vollero
QA Contact: Jaroslav Henner
URL:
Whiteboard:
Depends On: 1080424
Blocks: 1055536 foreman_vcenter_nova-net 1116136
TreeView+ depends on / blocked
 
Reported: 2014-02-04 17:26 UTC by Stephen Gordon
Modified: 2016-04-26 14:32 UTC (History)
11 users (show)

Fixed In Version: openstack-packstack-2013.2.1-0.32.dev1018.el6ost
Doc Type: Enhancement
Doc Text:
Packstack now supports the vCenter driver. With this, Packstack can now deploy OpenStack Compute as a VM manager for a vCenter host. This enhancement also adds the following relevant Packstack parameters: --os-vmware: enables VMWare features --vcenter-host: describes the vCenter host --vcenter-username: the vCenter username for the host --vcenter-password: the corresponding vCenter password for the supplied username --vcenter-cluster: the cluster where VMs will be running
Clone Of:
: foreman_vcenter_nova-net (view as bug list)
Environment:
Last Closed: 2014-05-29 19:57:42 UTC
Target Upstream Version:
ddomingo: needinfo? (fvollero)


Attachments (Terms of Use)
Upstream patch (deleted)
2014-05-09 18:44 UTC, Lon Hohberger
no flags Details | Diff
packstack_answerfile_part (deleted)
2014-05-19 18:03 UTC, Jaroslav Henner
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0577 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-05-29 23:55:40 UTC
OpenStack gerrit 75132 None None None Never
OpenStack gerrit 76621 None None None Never
OpenStack gerrit 92345 None None None Never
Red Hat Bugzilla 1096504 None None None Never

Internal Links: 1096504

Description Stephen Gordon 2014-02-04 17:26:02 UTC
Description of problem:

Add support for deploying compute to use an existing vCenter deployment and nova-networking to provide a PoC environment.

Comment 2 Ivan Chavero 2014-02-06 22:11:20 UTC
Checking nova configuracion for vCenter with the nova team.

dprince any pointers to documentation/examples?

Comment 4 Stephen Gordon 2014-03-06 13:36:02 UTC
(In reply to Ivan Chavero from comment #2)
> Checking nova configuracion for vCenter with the nova team.
> 
> dprince any pointers to documentation/examples?

http://docs.openstack.org/havana/config-reference/content/vmware.html

Comment 16 Jaroslav Henner 2014-04-16 15:19:22 UTC
packstack --gen-answer-file=foo; grep VCENTER foo | sort | uniq -d
CONFIG_VCENTER_HOST=
CONFIG_VCENTER_PASSWORD=
CONFIG_VCENTER_USER=

This means the same options are there twice. That's because they are defined for both, cinder as well as for nova.

Comment 17 Jaroslav Henner 2014-04-16 15:44:57 UTC
I also think we should be able to specify the datastore_regex

Comment 18 Stephen Gordon 2014-04-22 14:30:53 UTC
Francesco what's your take?

Comment 19 Stephen Gordon 2014-04-22 14:34:28 UTC
<fvollero> steveg: yeah, I have, and I spoke with jhenner about this
<fvollero> steveg: the failure is 'trivial' because packstack need to be executed with a specific commands, but anyway I have a patch almost done for that, but some other matters poppet out in the mean time and I had to move aside this one

Comment 20 Stephen Gordon 2014-04-30 17:10:53 UTC
(In reply to Jaroslav Henner from comment #16)
> packstack --gen-answer-file=foo; grep VCENTER foo | sort | uniq -d
> CONFIG_VCENTER_HOST=
> CONFIG_VCENTER_PASSWORD=
> CONFIG_VCENTER_USER=
> 
> This means the same options are there twice. That's because they are defined
> for both, cinder as well as for nova.

Just to confirm, how does the user specify which cluster(s) to use, or is that handled automatically?

Comment 21 Francesco Vollero 2014-05-06 11:03:08 UTC
Stephen, what jhenner advertised is not all the variables in play, because there is a variable called CONFIG_VCENTER_CLUSTER_NAME and at the actual status there is a flag --nova-vcenter-cluster-name that in my new patch gonna disappear to be renamed as --vcenter-cluster-name.

Comment 23 Stephen Gordon 2014-05-06 13:27:41 UTC
(In reply to Francesco Vollero from comment #21)
> Stephen, what jhenner advertised is not all the variables in play, because
> there is a variable called CONFIG_VCENTER_CLUSTER_NAME and at the actual
> status there is a flag --nova-vcenter-cluster-name that in my new patch
> gonna disappear to be renamed as --vcenter-cluster-name.

Ok thanks. For the PackStack support I think just one cluster is fine. For Foreman we will want to support multiple.

Comment 24 Francesco Vollero 2014-05-06 13:44:27 UTC
Yes, totally agree on that, due to the packstack nature a multiple datacenter is out of scope.
The puppet module surely allow you to do that with ease so foreman should be able to do it too.

Comment 25 Stephen Gordon 2014-05-08 18:42:59 UTC
What do I need to do to get your latest version in RDO as well - or is that good to go?

Comment 26 Francesco Vollero 2014-05-08 21:11:50 UTC
Martin, build the package in Icehouse but I am not sure that it include this patch yet. I will update this bug when I will have more informations.

Comment 27 Francesco Vollero 2014-05-08 21:12:23 UTC
Martin built the package in Icehouse but I am not sure that it include this patch yet. I will update this bug when I will have more informations.

Comment 28 Scott Lewis 2014-05-09 18:10:59 UTC
re-ack'd

Comment 30 Lon Hohberger 2014-05-09 18:44:26 UTC
Created attachment 894152 [details]
Upstream patch

Comment 31 Martin Magr 2014-05-12 09:10:26 UTC
Stephen, new features are first developed in most recent branch (Icehouse currently) and then are backported to older branches as is necessary. So you don't have to do anything. You will find the same functionality in most recent Icehouse version of Packstack.

Comment 32 Stephen Gordon 2014-05-13 02:43:38 UTC
(In reply to Martin Magr from comment #31)
> Stephen, new features are first developed in most recent branch (Icehouse
> currently) and then are backported to older branches as is necessary. So you
> don't have to do anything. You will find the same functionality in most
> recent Icehouse version of Packstack.

The version in RDO (at least for RHEL 6) is openstack-packstack-2014.1.1-0.9.dev1055.el6.noarch.rpm  but still lists all of the options in c#20, not the consolidated options referred to in the patch linked from comment # 30. That is why I am asking what needs to be done to get it in RDO, because it's not there today.

Comment 33 Martin Magr 2014-05-13 11:36:41 UTC
You should be holding the right package (except in dev1055 is paramater duplication in answer file):

[para@elysium Development]$ rpm -q openstack-packstack; packstack --gen-answer-file=test.txt; cat test.txt | grep -i vcenter
openstack-packstack-2014.1.1-0.9.dev1055.fc21.noarch
# Set to 'y' if you want to use VMware vCenter as hypervisor and
# The IP address of the VMware vCenter datastore
CONFIG_VCENTER_HOST=
# The username to authenticate to VMware vCenter datastore
CONFIG_VCENTER_USER=
# The password to authenticate to VMware vCenter datastore
CONFIG_VCENTER_PASSWORD=
# The IP address of the VMware vCenter server
CONFIG_VCENTER_HOST=
# The username to authenticate to VMware vCenter server
CONFIG_VCENTER_USER=
# The password to authenticate to VMware vCenter server
CONFIG_VCENTER_PASSWORD=
# The name of the vCenter cluster
CONFIG_VCENTER_CLUSTER_NAME=
[para@elysium Development]$ 

Gonna check el6 package too.

Comment 34 Martin Magr 2014-05-13 11:40:11 UTC
[para@virtual-rhel ~]$ rpm -q openstack-packstack; packstack --gen-answer-file=test.txt; cat test.txt | grep -i vcenter
openstack-packstack-2014.1.1-0.9.dev1055.el6.noarch
# Set to 'y' if you want to use VMware vCenter as hypervisor and
# The IP address of the VMware vCenter datastore
CONFIG_VCENTER_HOST=
# The username to authenticate to VMware vCenter datastore
CONFIG_VCENTER_USER=
# The password to authenticate to VMware vCenter datastore
CONFIG_VCENTER_PASSWORD=
# The IP address of the VMware vCenter server
CONFIG_VCENTER_HOST=
# The username to authenticate to VMware vCenter server
CONFIG_VCENTER_USER=
# The password to authenticate to VMware vCenter server
CONFIG_VCENTER_PASSWORD=
# The name of the vCenter cluster
CONFIG_VCENTER_CLUSTER_NAME=
[para@virtual-rhel ~]$ 

The same is for el6 package.

Comment 35 Stephen Gordon 2014-05-13 13:13:15 UTC
Ok, so why are they all listed twice. That's exactly what we were supposed to be removing, no?

Comment 36 Francesco Vollero 2014-05-13 14:51:43 UTC
Stephen, I guess the release 1055 does not have the right patch.

In fact if you use my last patch from gerrit (92345) and run the same command as Martin, you will see:
[fvollero@nosside]~/tmp/packstack-vcenter% bin/packstack --gen-answer-file=test.txt; cat test.txt | grep -i vcenter

# Set to 'y' if you want to use VMware vCenter as hypervisor and
# The IP address of the VMware vCenter server
CONFIG_VCENTER_HOST=
# The username to authenticate to VMware vCenter server
CONFIG_VCENTER_USER=
# The password to authenticate to VMware vCenter server
CONFIG_VCENTER_PASSWORD=
# The name of the vCenter cluster
CONFIG_VCENTER_CLUSTER_NAME=

Comment 37 Martin Magr 2014-05-14 14:13:58 UTC
Stephen, patch which removed parameter duplication is contained in later release (dev1065+). Hopefully RDO Icehouce will be updated soon. The same patch will be contained in next 4.0.z release.

Note that nevertheless the parameter duplication, vCenter is installable even with dev1055 release. You just have to use command line parameters if you want to have different vCenter settings for Nova and Cinder.

Note that from dev1065+ releases it will be possible to use only one vCenter for both Nova and Cinder.

Comment 38 Jaroslav Henner 2014-05-19 18:03:26 UTC
Created attachment 897266 [details]
packstack_answerfile_part

packstack fails to configure the cinder when using the attached answerfile:

[root@jhenner-node ~]# grep vmw /etc/cinder/cinder.conf 
# Options defined in cinder.volume.drivers.vmware.vmdk
#vmware_host_ip=<None>
#vmware_host_username=<None>
#vmware_host_password=<None>
#vmware_wsdl_location=<None>
#vmware_api_retry_count=10
#vmware_task_poll_interval=5
#vmware_volume_folder=cinder-volumes
#vmware_image_transfer_timeout_secs=7200
#vmware_max_objects_retrieval=100

Comment 39 Francesco Vollero 2014-05-20 19:08:43 UTC
I tried to reproduce the bug, but with the latest master (not changing anything) and what you got is "ODD" 

again, to run packstack I executed this command:
./bin/packstack --allinone --use-epel=y --os-vmware=y --vcenter-host=1.2.3.4 --vcenter-username=root --vcenter-password=vmware --vcenter-cluster=foo --cinder-backend=vmdk


[root@rhel-packstack packstack]# grep 'vmw' /etc/cinder/cinder.conf | grep -v '^#'
vmware_host_ip=1.2.3.4
vmware_host_username=root
vmware_host_password=vmware
vmware_api_retry_count=10
vmware_task_poll_interval=5
vmware_volume_folder=cinder-volumes
vmware_image_transfer_timeout_secs=7200
volume_driver=cinder.volume.drivers.vmware.vmdk.VMwareVcVmdkDriver
vmware_max_object_retrieval=100

And, I don't get any duplicated parameters on the answer file.

[root@rhel-packstack packstack]# grep -ri vcenter ../packstack-answers-20140520-203033.txt 
# Set to 'y' if you want to use VMware vCenter as hypervisor and
# The IP address of the VMware vCenter server
CONFIG_VCENTER_HOST=1.2.3.4
# The username to authenticate to VMware vCenter server
CONFIG_VCENTER_USER=root
# The password to authenticate to VMware vCenter server
CONFIG_VCENTER_PASSWORD=vmware
# The name of the vCenter cluster
CONFIG_VCENTER_CLUSTER_NAME=foo
[root@rhel-packstack packstack]#

Comment 40 Francesco Vollero 2014-05-20 19:09:51 UTC
Just adding a note, I don't know what is actually happening here but I have a strong point that the 1055 still not have the commit 31891ae that fix the duplication for some reason.

Comment 41 Lon Hohberger 2014-05-20 21:04:31 UTC
I read the puppet modules, it sounds like what Francesco pointed out - --cinder-backend=vmdk needs to be turned on to use VMware for storage.

Comment 42 Jaroslav Henner 2014-05-21 08:27:29 UTC
Fool me, Francesco was right.

After adding the
CONFIG_CINDER_BACKEND=vmdk

I have got:
[root@jenkins-a5a418f6-6 ~]# grep ^vmware /etc/cinder/cinder.conf 
vmware_host_ip=10.34.69.76
vmware_host_username=root
vmware_host_password=vmware
vmware_api_retry_count=10
vmware_task_poll_interval=5
vmware_volume_folder=cinder-volumes
vmware_image_transfer_timeout_secs=7200
vmware_max_object_retrieval=100

Comment 43 Jaroslav Henner 2014-05-21 13:08:03 UTC
Most of the tempest tests, nova boot, volume attach of volume in vSphere works fine after deploying with packstack.

Comment 46 errata-xmlrpc 2014-05-29 19:57:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0577.html


Note You need to log in before you can comment on or make changes to this bug.