Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061349 - neutron-dhcp-agent won't start due to a missing import of module named stevedore
Summary: neutron-dhcp-agent won't start due to a missing import of module named stevedore
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: openstack-neutron
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-04 16:29 UTC by Nir Magnezi
Modified: 2016-01-04 17:42 UTC (History)
3 users (show)

Fixed In Version: openstack-neutron-2014.1-0.5.b2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-04 17:42:09 UTC


Attachments (Terms of Use)

Description Nir Magnezi 2014-02-04 16:29:05 UTC
Description of problem:
=======================
Found when I tried to verify bug #1061055
neutron-dhcp-agent won't start due to a missing import of module named stevedore.
installed the neutron-dhcp-agent on a dedicated node which only populates that service.

Version-Release number of selected component (if applicable):
=============================================================
openstack-neutron-2014.1-0.4.b2.el6.noarch

How reproducible:
=================
2/2

Steps to Reproduce:
===================
1. Install RDO on RHEL6.5 , allocate a dedicated node to host the neutron-dhcp service.
2.

Actual results:
===============

# service neutron-dhcp-agent status
neutron-dhcp-agent dead but pid file exists

# /usr/bin/python /usr/bin/neutron-dhcp-agent --log-file /var/log/neutron/dhcp-agent.log --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/dhcp_agent.ini
Traceback (most recent call last):
  File "/usr/bin/neutron-dhcp-agent", line 6, in <module>
    from neutron.agent.dhcp_agent import main
  File "/usr/lib/python2.6/site-packages/neutron/agent/dhcp_agent.py", line 27, in <module>
    from neutron.agent.linux import interface
  File "/usr/lib/python2.6/site-packages/neutron/agent/linux/interface.py", line 29, in <module>
    from neutron.extensions.flavor import (FLAVOR_NETWORK)
  File "/usr/lib/python2.6/site-packages/neutron/extensions/flavor.py", line 18, in <module>
    from neutron.api import extensions
  File "/usr/lib/python2.6/site-packages/neutron/api/extensions.py", line 33, in <module>
    from neutron.manager import NeutronManager
  File "/usr/lib/python2.6/site-packages/neutron/manager.py", line 28, in <module>
    from stevedore import driver
ImportError: No module named stevedore

Expected results:
=================
service should be running.

Additional info:
================
workaround: pip install stevedore

Comment 1 Lars Kellogg-Stedman 2014-02-04 17:32:02 UTC
The missing stevedore requirement also prevents neutron-db-manage from running, which prevents a successful install via packstack.

The workaround should probably be "yum install python-stevedore" (using "pip" may get you a version of stevedore different from that available via packacges, which could result in new problems or masking ones in the package).

Comment 3 Assaf Muller 2016-01-04 17:42:09 UTC
I can confirm that RDO 5 on RHEL 6 has "stevedore" as required in its spec file. Closing as the 'ON_QA' stage is not relevant for RDO.


Note You need to log in before you can comment on or make changes to this bug.