Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061280 - [RFE][savanna]: Extended information about node processes
Summary: [RFE][savanna]: Extended information about node processes
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact:
URL: https://blueprints.launchpad.net/saha...
Whiteboard: upstream_milestone_next upstream_stat...
: 1075343 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-04 15:43 UTC by RHOS Integration
Modified: 2014-03-31 04:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-19 13:09:12 UTC


Attachments (Terms of Use)

Description RHOS Integration 2014-02-04 15:43:38 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/savanna/+spec/node-processes-details.

Description:

It'll be better if plugin will return extended information about node processes to improve savanna-side validation and to add some additional validation at UI side.

Here is a list of potential constraints for node processes:

* min_instances (1 / None) - means that each cluster should have at least N instances of the specific node process;

* max_instances (2 / None) - means that each cluster should have maximum N instances of the specific node process;

* is_scalable (True / False) - defines could the specific node process be scaled or not;

* anti_affinity_applicable (True / False) - should we display specific process in the list of AA processes? (looks like it's not needed if we'll have min/max instance).

TBD: add more details about Plugin SPI and REST API

Specification URL (additional information):

None

Comment 1 Stephen Gordon 2014-03-12 15:31:47 UTC
*** Bug 1075343 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.