Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061249 - [RFE][savanna]: Integration of the Intel Distributon of Apache Hadoop with Savanna
Summary: [RFE][savanna]: Integration of the Intel Distributon of Apache Hadoop with Sa...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 5.0 (RHEL 7)
Assignee: RHOS Maint
QA Contact:
URL: https://blueprints.launchpad.net/saha...
Whiteboard: upstream_milestone_icehouse-2 upstrea...
: 1074785 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-04 15:33 UTC by RHOS Integration
Modified: 2014-09-08 05:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Technology Preview
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-19 13:05:45 UTC


Attachments (Terms of Use)

Description RHOS Integration 2014-02-04 15:33:03 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/savanna/+spec/idh-savanna-plugin.

Description:

IDH plugin with following features:

* Install and provision Intel Hadoop Manager and Intel Hadoop
* Attach Cinder volumes to VMs with Intel Hadoop. Cinder volumes will be used for HDFS
* Manual cluster scaling
* Swift integration [*]
* Cluster configs - the same configs as in Vanilla Hadoop
* Configs validation - the same as in Vanilla plugin



[*] Swift integration is an important point. Swift is de-facto cloud storage in OpenStack environment for permanent data. But it is not a replacement for HDFS.

What it requires to integrate IDH with Swift? We only need to include jar file with implementation of SwiftFileSystem for Hadoop and update core-site.xml to include this implementation. And we already have this integrated IDH with Swift.


Specification URL (additional information):

https://wiki.openstack.org/wiki/Savanna/idhplugin

Comment 1 Stephen Gordon 2014-02-06 14:12:11 UTC
Updating based on BP milestone

Comment 2 Stephen Gordon 2014-03-12 15:23:48 UTC
*** Bug 1074785 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.