Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061237 - [RFE][savanna]: Integration with Ceilometer
Summary: [RFE][savanna]: Integration with Ceilometer
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Upstream M3
: ---
Assignee: RHOS Maint
QA Contact:
URL: https://blueprints.launchpad.net/saha...
Whiteboard: upstream_milestone_juno-3 upstream_st...
: 1074797 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-04 15:29 UTC by RHOS Integration
Modified: 2014-10-05 01:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-19 13:04:36 UTC


Attachments (Terms of Use)

Description RHOS Integration 2014-02-04 15:29:25 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/savanna/+spec/ceilometer-integration.

Description:

It'll be great to have some ability to report/query metrics for Savanna.

There are two possible points of integration:

* report overall Savanna stats to Ceilometer (number of clusters/instances/volumes used overall/per-tenant/per-user/etc, size of clusters, used plugin/version, etc.)

* report metrics from each cluster (it could be implemented by adding new method to plugin that would be called to get some metrics, for example, number of mar/reduce tasks, health checks, hdfs free space, etc.)

Specification URL (additional information):

None

Comment 1 Stephen Gordon 2014-03-12 15:20:47 UTC
*** Bug 1074797 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.