Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061188 - Cairo generates PDFs with wrong font names
Summary: Cairo generates PDFs with wrong font names
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cairo
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Benjamin Otte
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-04 14:18 UTC by Marek Kašík
Modified: 2014-06-18 08:44 UTC (History)
3 users (show)

Fixed In Version: cairo-1.12.14-6.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 13:05:35 UTC


Attachments (Terms of Use)
reproducer (deleted)
2014-02-04 14:18 UTC, Marek Kašík
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 73441 None None None Never

Description Marek Kašík 2014-02-04 14:18:28 UTC
Created attachment 859167 [details]
reproducer

Description of problem:
Cairo exports font names in their original form. But these can be wrong, they can sometimes contain white space characters or PDF/PostScript delimiter characters. Such fonts are not common but they appear.

This can cause a problem when you are printing such file in evince. The printing fails during processing of an intermediate PDF because there are delimiter characters where they shouldn't be.


Version-Release number of selected component (if applicable):
cairo-1.12.14-5.el7


How reproducible:
Always


Steps to Reproduce:
1. run "pdftocairo -pdf test-cff.pdf result.pdf"


Actual results:
Font names in result.pdf contain white-spaces characters and delimiter characters.


Expected results:
Font names in result.pdf don't contain white-spaces characters and delimiter characters.


Additional info:
Fix was already pushed upstream, see https://bugs.freedesktop.org/show_bug.cgi?id=73441.

Comment 4 Ludek Smid 2014-06-13 13:05:35 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.