Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061181 - [RHEV] (6.2.x) The upgrade of the AS from EAP 6.2.0 to 6.2.1 caused a problem in jboss-as-naming for RHEV
Summary: [RHEV] (6.2.x) The upgrade of the AS from EAP 6.2.0 to 6.2.1 caused a problem...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Naming
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: CR4
: EAP 6.2.1
Assignee: Carlo de Wolf
QA Contact: Josef Cacek
URL:
Whiteboard:
Depends On: 1060275
Blocks: eap62-cp01-blockers 1060867
TreeView+ depends on / blocked
 
Reported: 2014-02-04 14:05 UTC by Carlo de Wolf
Modified: 2014-02-24 20:15 UTC (History)
11 users (show)

Doc Type: Known Issue
Doc Text:
An upgrade to the jboss-as-naming package has resulted in the failure of LDAP-specific methods such as getRequestControls. The root cause is that during startup the new version of the jboss-as-naming package is registering an InitialContextFactoryBuilder class that ignores the Context.INITIAL_CONTEXT_FACTORY property given by the user. In some instances this can result in an InvalidNameException error. No known workaround is available but it is expected to be resolved in a future update patch update. Result:
Clone Of: 1060275
Environment:
Last Closed: 2014-02-24 20:15:08 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2319 Major Resolved LDAP Search containing URL - InvalidNameException: ldap:: [LDAP: error code 34 - Invalid root Dn given 2014-06-25 13:57:12 UTC

Comment 1 Russell Dickenson 2014-02-11 04:26:58 UTC
Attention: Carlo

I have drafted a release notes entry for this BZ ticket but I need your review to ensure it is accurate.

Comment 2 Josef Cacek 2014-02-11 13:35:23 UTC
Verified in 6.2.1.CP.CR4.

Comment 3 Russell Dickenson 2014-02-11 13:57:12 UTC
After checking with Carlo, I realised that since this issue could not have affected a customer, a RN entry is not applicable. I have therefore cleared the flag.


Note You need to log in before you can comment on or make changes to this bug.