Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061160 - libguestfs source has bogus COPYING file
Summary: libguestfs source has bogus COPYING file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1062533 1062890
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-04 13:10 UTC by Richard W.M. Jones
Modified: 2014-06-18 02:02 UTC (History)
5 users (show)

Fixed In Version: libguestfs-1.22.6-19.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 10:14:06 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-02-04 13:10:17 UTC
Description of problem:

Matt Booth was doing the PackageWranger review of libguestfs and
we noticed there was a bogus license file (daemon/COPYING) which
asserted that the daemon was under GPLv3.  It is not, it is under
GPLv2+, and we have removed that file from upstream:

https://github.com/libguestfs/libguestfs/commit/d5b540153fa91230524133c09c879199b8e2d902

Normally I would ignore this, but because of bug 1061155 it
looks like we are going to do another build anyway, so we can
fix this at the same time.

Version-Release number of selected component (if applicable):

libguestfs-1.22.6-18.el7

How reproducible:

100%

Steps to Reproduce:
1. Check out the SRPM.
2. Apply all patches (ie. do 'rhpkg prep').
3. Check daemon/COPYING file.

Actual results:

This file exists and says the daemon is under GPLv3.

Expected results:

This file should not exist.  The daemon is under GPLv2+ as
asserted in individual files and by COPYING in the top level
directory.

Additional info:

Comment 2 bfan 2014-02-10 09:13:27 UTC
Verified with libguestfs-1.22.6-19.el7.x86_64

# rpm -ivh libguestfs-1.22.6-19.el7.src.rpm
# cd ~/rpmbuild/SPECS/
# rpmbuild -bp libguestfs.spec

# ll ~/rpmbuild/BUILD/libguestfs-1.22.6/daemon/COPYING
ls: cannot access /root/rpmbuild/BUILD/libguestfs-1.22.6/daemon/COPYING: No such file or directory

Comment 3 Ludek Smid 2014-06-13 10:14:06 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.