Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061005 - error page when clicking on the Orchestration -> Stacks link
Summary: error page when clicking on the Orchestration -> Stacks link
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RDO
Classification: Community
Component: python-django-horizon
Version: unspecified
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-04 07:44 UTC by Ami Jeain
Modified: 2014-02-04 12:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-04 12:50:57 UTC


Attachments (Terms of Use)

Description Ami Jeain 2014-02-04 07:44:22 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. login to horizon (with Heat installation)
2. click on Project Tab -> Orchestration -> Stacks link
3.

Actual results:

the web page throws a "something went wrong" error

Expected results:

either should show the stacks, or if empty, should show "no data to display"

Additional info:

looking at the /var/log/httpd/access_log file:

10.35.7.45 - - [04/Feb/2014:09:41:40 +0200] "GET /dashboard/project/stacks/ HTTP/1.1" 500 1749 "http://puma36.scl.lab.tlv.redhat.com/dashboard/project/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.93 Safari/537.36"

Comment 1 Amit Ugol 2014-02-04 08:11:38 UTC
Supplemental:

when clicking on the 'stacks' link, this is the error output in /var/log/horizon/horizon.log

  2014-02-04 08:02:33,025 23579 ERROR django.request Internal Server Error: /dashboard/project/stacks/
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/django/core/handlers/base.py", line 115, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 38, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 54, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 38, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 86, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/django/views/generic/base.py", line 68, in view
    return self.dispatch(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/django/views/generic/base.py", line 86, in dispatch
    return handler(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/tables/views.py", line 154, in get
    handled = self.construct_tables()
  File "/usr/lib/python2.7/site-packages/horizon/tables/views.py", line 145, in construct_tables
    handled = self.handle_table(table)
  File "/usr/lib/python2.7/site-packages/horizon/tables/views.py", line 118, in handle_table
    data = self._get_data_dict()
  File "/usr/lib/python2.7/site-packages/horizon/tables/views.py", line 181, in _get_data_dict
    self._data = {self.table_class._meta.name: self.get_data()}
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/dashboards/project/stacks/views.py", line 53, in get_data
    exceptions.handle(request, _('Unable to retrieve stack list.'))
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/dashboards/project/stacks/views.py", line 51, in get_data
    stacks = api.heat.stacks_list(self.request)
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/api/heat.py", line 56, in stacks_list
    return [stack for stack in heatclient(request).stacks.list()]
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/api/heat.py", line 36, in heatclient
    endpoint = base.url_for(request, 'orchestration')
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/api/base.py", line 270, in url_for
    raise exceptions.ServiceCatalogException(service_type)
ServiceCatalogException: Invalid service catalog service: orchestration


* system was installed with packstack --allinone
* cat /etc/redhat-release 
Fedora release 20 (Heisenbug)
* uname -a
  Linux puma36.scl.lab.tlv.redhat.com 3.12.9-301.fc20.x86_64 #1 SMP Wed Jan 29 15:56:22 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
* yum info python-django.noarch
  Loaded plugins: priorities
  152 packages excluded due to repository priority protections
  Installed Packages
  Name        : python-django
  Arch        : noarch
  Version     : 1.5.5
  Release     : 2.fc20

Comment 2 Matthias Runge 2014-02-04 08:15:20 UTC
Thanks for the bug report.

However:
    raise exceptions.ServiceCatalogException(service_type)
ServiceCatalogException: Invalid service catalog service: orchestration

Sounds really bad and points me first to a config issue.

Could you please provide the output of keystone catalog ?

Comment 3 Ami Jeain 2014-02-04 08:35:17 UTC
hey Matthias,

Service: orchestration
+-------------+-----------------------------------------------------------+
|   Property  |                           Value                           |
+-------------+-----------------------------------------------------------+
|   adminURL  | http://localhost:8004/v1/841f6a8d9be5457897f7fdb8e20decc3 |
|      id     |              13a8bbc5927c4bdd91225d90c1bf521e             |
| internalURL | http://localhost:8004/v1/841f6a8d9be5457897f7fdb8e20decc3 |
|  publicURL  | http://localhost:8004/v1/841f6a8d9be5457897f7fdb8e20decc3 |
|    region   |                         regionOne                         |
+-------------+-----------------------------------------------------------+

I am looking at the output and I see an issue where the service was registered with localhost as the 'hostname' instead of the real hostname. fixing it and will let u know...

Comment 4 Julie Pichon 2014-02-04 09:38:28 UTC
Consider also checking that the region name matches the other services' regions.

Comment 5 Amit Ugol 2014-02-04 12:50:57 UTC
closing as invalid


Note You need to log in before you can comment on or make changes to this bug.