Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060897 - Test case failure: Layout indicator
Summary: Test case failure: Layout indicator
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-settings
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ngo Than
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-03 21:01 UTC by Vasiliy Sharapov
Modified: 2014-02-06 13:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-06 13:25:47 UTC


Attachments (Terms of Use)
Layout indicator in lower-right corner (deleted)
2014-02-03 21:01 UTC, Vasiliy Sharapov
no flags Details

Description Vasiliy Sharapov 2014-02-03 21:01:37 UTC
Created attachment 858862 [details]
Layout indicator in lower-right corner

Filed from caserun https://tcms.engineering.redhat.com/run/114441/#caserun_4273988

Version-Release number of selected component (if applicable):
RHEL-7.0-20140110.0

Steps to Reproduce: 
 1. Boot into a default KDE session
 2. Run SystemSettings
 3. Go to the Input Devices module


 1. Go to the Layouts Page
 2. Have the 'Configure layouts' toggle checked
 3. In addition to your default language, choose a couple more different
    languages and add them in the list
 4. In the Layout Indicator section have the 'Show Layout indicator' checked
 5. Apply.
 6. Now uncheck it
 7. Apply.
 8. Choose to Show Flag
 9. Apply.



Actual results: 
Flag indicator does not appear, regular ISO language codes appear - same as "label" setting.

Expected results:
You can see the layout indicator tray icon only when checked and a flag instead
of country code when selected.

Comment 2 Ngo Than 2014-02-06 13:25:47 UTC
it's intention that we removed all flags because some people/countries forbid some other people/countries' flags. It's requirement to remove flags in rhel, since rhel4


Note You need to log in before you can comment on or make changes to this bug.