Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060892 - iSCSI BFS LUN does not show up in anaconda if local HD is present
Summary: iSCSI BFS LUN does not show up in anaconda if local HD is present
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-03 20:35 UTC by edwardn
Modified: 2014-02-04 18:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-04 18:59:51 UTC


Attachments (Terms of Use)
Local HD present (failure case) (deleted)
2014-02-03 20:36 UTC, edwardn
no flags Details
Local HD not present (working case) (deleted)
2014-02-03 20:36 UTC, edwardn
no flags Details

Description edwardn 2014-02-03 20:35:29 UTC
Description of problem:
iSCSI BFS LUN does not show up in anaconda if local HD is present

Version-Release number of selected component (if applicable):
SS4 image, anaconda-19.31.51-1

How reproducible:
multiple systems, 100% of the time

Steps to Reproduce:
1. Have local HD present
2. Configure Broadcom boot rom to log into iSCSI target
3. Start the installation from the CD
4. Once in GUI, notice that the iSCSI LUN is not shown as an available disk.  When going to ttyS2, notice that the target is logged in.
5. Repeat the above steps with the local HD removed.  The iSCSI LUN will show in the GUI as an available disk to install to.

Actual results:
Unable to install to iSCSI LUN if local HD is present

Expected results:
Able to install to iSCSI LUN even if local HD is present

Additional info:
- Logs attached for both working(no local HD present) and failing(local HD present) cases.

Comment 1 edwardn 2014-02-03 20:36:14 UTC
Created attachment 858856 [details]
Local HD present (failure case)

Comment 2 edwardn 2014-02-03 20:36:39 UTC
Created attachment 858857 [details]
Local HD not present (working case)

Comment 4 Radek Vykydal 2014-02-04 10:43:13 UTC
Isn't the problem the iSCSI disk just not being selected by default in non-working case because local HD is selected? In this case you need to go to Specialzed & Network Disks (click [Add a disk]) and then check the disk in advanced storage screen so that the disk is visible and selectable in Device Selection screen.

Comment 5 edwardn 2014-02-04 18:59:51 UTC
(In reply to Radek Vykydal from comment #4)
> Isn't the problem the iSCSI disk just not being selected by default in
> non-working case because local HD is selected? In this case you need to go
> to Specialzed & Network Disks (click [Add a disk]) and then check the disk
> in advanced storage screen so that the disk is visible and selectable in
> Device Selection screen.

You are absolutely correct.  Just checked again and the iSCSI disk does show up when drilling down a little further.  The confusion must've been while we were troubleshooting an earlier snapshot which needed extra kernel parameters and were having trouble getting the disk to appear during installation.  Not an issue... closing.


Note You need to log in before you can comment on or make changes to this bug.