Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060834 - Consistently use "Deleted" in REST responses
Summary: Consistently use "Deleted" in REST responses
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Master
Version: 1.x
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Dan McPherson
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks: 1067308
TreeView+ depends on / blocked
 
Reported: 2014-02-03 17:45 UTC by Oleg Fayans
Modified: 2016-12-01 00:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1067308 (view as bug list)
Environment:
Last Closed: 2014-03-12 03:06:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Oleg Fayans 2014-02-03 17:45:25 UTC
Description of problem:
We should use the similar output messages for actions of the same kind. For example, when I delete an ssh key via REST, it tells me "Deleted SSH key", 
When I delete the authorization token, it says "Authorization <%token_id%> is revoked", when I delete an alias, it says: "Removed alias.com from application"
Let's put some consistency to the REST responses
 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dan McPherson 2014-02-06 19:26:58 UTC
I disagree that everything should be deleted.  Consistency within a type if important.  We don't want to use both delete and destroy and remove for one type of object.  But revoke is a better word for auth.  I actually like removed better for alias and I would prefer removed for ssh key.  The reason why is because remove implies the app is still there and you have taken something away from it.  You aren't actually deleting the key.  It still exists.  It's just not a part of the app.  I went ahead and changed it for ssh key.


https://github.com/openshift/origin-server/pull/4676

Comment 3 Jianwei Hou 2014-02-07 05:21:18 UTC
Verified on devenv_4341, the RESTAPI messages have been improved when an sshkey is deleted.

{"api_version":1.6,"data":null,"messages":[{"exit_code":0,"field":null,"index":null,"severity":"info","text":"Removed SSH key default"}],"status":"ok","supported_api_versions":[1.0,1.1,1.2,1.3,1.4,1.5,1.6],"type":null,"version":"1.6"}


Note You need to log in before you can comment on or make changes to this bug.