Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060816 - null pointer exception when re-open the guided rule
Summary: null pointer exception when re-open the guided rule
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 5.x.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER1
: 6.0.2
Assignee: manstis
QA Contact: Jiri Locker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-03 16:55 UTC by Jey
Modified: 2014-08-06 19:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 19:53:44 UTC
Type: Bug


Attachments (Terms of Use)
null pointer exception while re-open the guided rule (deleted)
2014-02-03 16:55 UTC, Jey
no flags Details
ResourceAssignmentModel.jar (deleted)
2014-03-26 13:32 UTC, Jiri Locker
no flags Details

Description Jey 2014-02-03 16:55:12 UTC
Created attachment 858702 [details]
null pointer exception while re-open the guided rule

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

please see attachment

Comment 4 manstis 2014-02-10 10:50:49 UTC
I tried to recreate the rule; however have not been able to without the data model. Please provide more information. Thanks.

Comment 5 Jiri Locker 2014-03-26 13:32:51 UTC
Created attachment 879003 [details]
ResourceAssignmentModel.jar

Hi Mike, I tried to imitate the model and I reproduced the null error when reopening the rule with it. Please try.

Comment 6 Jiri Locker 2014-03-26 13:36:55 UTC
1. upload the model jar in Artifact repository
2. create new project org.sample:resourceAssignment:1.0 (use this group and artifact IDs to hava access to model classes without importing them)
3. add the model jar as project dependency
4. create new guided rule, add the described content
5. validate, save, close, reopen

Comment 9 Jiri Locker 2014-05-07 14:22:32 UTC
I was able to create the rule, validation passed. I saved the rule, closed it and reopened OK. Some of the freeform DRL elements changed to formulas but the re-genereted DLR source stayed the same (as expected).


Note You need to log in before you can comment on or make changes to this bug.