Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060654 - Regression test failure while mounting nfs
Summary: Regression test failure while mounting nfs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-03 08:35 UTC by Vijay Bellur
Modified: 2014-11-11 08:27 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-11 08:27:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
packet capture (deleted)
2014-02-04 16:10 UTC, Vijay Bellur
no flags Details

Description Vijay Bellur 2014-02-03 08:35:12 UTC
Description of problem:

tests/basic/mount.t fails consistently on CentOS 6.3 if no sleep is present between portmap registration and the next mount attempt. If mount is attempted after 30-40 seconds, the mount is successful.

+ _TEST 58 mount -t nfs -o nolock,soft,intr build.gluster.org:/patchy /mnt/nfs/0
+ TESTLINE=58
+ shift
+ local redirect=
+ test_header mount -t nfs -o nolock,soft,intr build.gluster.org:/patchy /mnt/nfs/0
+ dbg =========================
+ '[' x0 = x0 ']'
+ dbg 'TEST 17 (line 58): mount -t nfs -o nolock,soft,intr build.gluster.org:/patchy /mnt/nfs/0'
+ '[' x0 = x0 ']'
+ '[' mount = '!' ']'
+ eval mount -t nfs -o nolock,soft,intr build.gluster.org:/patchy /mnt/nfs/0
++ mount -t nfs -o nolock,soft,intr build.gluster.org:/patchy /mnt/nfs/0
mount.nfs: mount system call failed
tests/basic/mount.t .......... Dubious, test returned 32 (wstat 8192, 0x2000)
Failed 14/30 subtests 

Test Summary Report
-------------------
tests/basic/mount-options.t (Wstat: 0 Tests: 90 Failed: 1)
  Failed test:  15
tests/basic/mount.t        (Wstat: 8192 Tests: 16 Failed: 0)
  Non-zero exit status: 32
  Parse errors: Bad plan.  You planned 30 tests but ran 16.
Files=2, Tests=106, 31 wallclock secs ( 0.06 usr  0.02 sys +  2.07 cusr  2.81 csys =  4.96 CPU)
Result: FAIL
Export list for build.gluster.org:
/patchy *
Thu Jan 30 11:10:48 PST 2014
mount.nfs: mount system call failed

It is to be noted that this failure is being observed after introduction of tests/basic/mount-options.t.


Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2014-02-04 16:10:11 UTC
Created attachment 859227 [details]
packet capture

Comment 2 Anand Avati 2014-02-05 16:24:22 UTC
REVIEW: http://review.gluster.org/6911 (tests/basic: Prevent mount-options.t from being run.) posted (#1) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 3 Anand Avati 2014-02-06 04:08:07 UTC
COMMIT: http://review.gluster.org/6911 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit b187d3b5231406b524bf73b45f76e001692e282e
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Wed Feb 5 21:50:20 2014 +0530

    tests/basic: Prevent mount-options.t from being run.
    
    mount-options.t introduces a race leading to failures in
    regression tests. Hence disabling the test unit till we
    sort out the race.
    
    Also removing the workaround introduced in mount.t.
    
    Change-Id: I7d60413bbff8597f90153cca838e326247e96cd9
    BUG: 1060654
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/6911
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Niels de Vos 2014-07-05 15:28:56 UTC
From the packet capture it is not clear why the mount would have failed. All the portmapper requests that have been captured show a successful call/reply (except for MOUNT over UDP, but TCP is requested and succeeds after that).

I plan to debug this a little further:
- run the Gluster/NFS server with log-level=TRACE
- run 'mount -vvv ...' to capture more details of the mount action

Comment 5 Anand Avati 2014-07-05 19:49:46 UTC
REVIEW: http://review.gluster.org/8243 (tests/basic: re-enable mount-options.t) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 6 Niels de Vos 2014-09-22 12:35:39 UTC
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/

Comment 7 Niels de Vos 2014-11-11 08:27:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users


Note You need to log in before you can comment on or make changes to this bug.