Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060645 - Not able to start the server with hostname as binding address
Summary: Not able to start the server with hostname as binding address
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: IPv6 support
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Pavel Slavicek
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-03 07:31 UTC by Abdul Basith
Modified: 2014-07-18 16:48 UTC (History)
1 user (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 16:48:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Abdul Basith 2014-02-03 07:31:29 UTC
Description of problem:
Need to start the server using standalone-full.xml in standalone mode, by replacing the addresses 127.0.0.1 with my server hostname. But its failing and not able to bind.

Version-Release number of selected component (if applicable):
EAP-6.2.0

How reproducible:

Steps to Reproduce:
1. Download eap-6.2.0 and replace the 127.0.0.1 in standalone-full.xml with hostname in all four places.

2. Use the following script to start the server.
sh ${JBOSS_HOME}/bin/standalone.sh -Djboss.server.default.config=standalone-full.xml -b 0.0.0.0 &


Actual results:
WARN  [org.jboss.as.controller] (MSC service thread 1-109) JBAS014622: Value '<<ip>>' for interface selection criteria 'inet-address' is ambiguous, as more than one address or network interface available on the machine matches it. Because of this ambiguity, no address will be selected as a match. Matching addresses: [<<hostname>>/<<ip>>].  Matching network interfaces: [eth0, bond0].

12:58:00,937 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-109) MSC000001: Failed to start service jboss.network.unsecure: org.jboss.msc.service.StartException in service jboss.network.unsecure: JBAS015810: failed to resolve interface unsecure

Expected results:
It should start and bind with the hostname of the server.

Additional info:
With the same set of configuration in Jboss-as-7.1.1.Final I'm able to start the server without any problem. And its binding with my hostname and IP address

Comment 1 Abdul Basith 2014-02-03 07:40:56 UTC
I'm running on RedHat Enterprise Server-5.8

Comment 2 Brian Stansberry 2014-07-18 16:48:32 UTC
This is not a bug; the behavior is as intended. If the inet-address criteria is used the value must resolve to single network interface; otherwise the behavior of the system will be indeterminate. In your case it resolved to two interfaces, eth0 and bond0.

The AS 7.1.1 behavior was a bug. See https://issues.jboss.org/browse/AS7-4509.


Note You need to log in before you can comment on or make changes to this bug.