Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060634 - [abrt] recoll: ole.py:431:getSectorIDChain:IndexError: list index out of range
Summary: [abrt] recoll: ole.py:431:getSectorIDChain:IndexError: list index out of range
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: recoll
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:9a4c98d274990e498a4993c53d0...
: 1064151 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-03 06:29 UTC by Koen
Modified: 2014-06-30 10:27 UTC (History)
5 users (show)

Fixed In Version: recoll-1.19.13-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-30 10:25:28 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-02-03 06:29 UTC, Koen
no flags Details
File: environ (deleted)
2014-02-03 06:29 UTC, Koen
no flags Details

Description Koen 2014-02-03 06:29:15 UTC
Description of problem:
Report was generated by ABRT.

Version-Release number of selected component:
recoll-1.19.11-1.fc20

Additional info:
reporter:       libreport-2.1.11
cmdline:        python2 /usr/share/recoll/filters/ppt-dump.py --no-struct-output --dump-text /tmp/rcltmpfaeOjqZ.pot
executable:     /usr/share/recoll/filters/ppt-dump.py
kernel:         3.12.8-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            500

Truncated backtrace:
ole.py:431:getSectorIDChain:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/share/recoll/filters/ppt-dump.py", line 141, in <module>
    main(sys.argv)
  File "/usr/share/recoll/filters/ppt-dump.py", line 135, in main
    if not dumper.dump():
  File "/usr/share/recoll/filters/ppt-dump.py", line 66, in dump
    strm.printDirectory()
  File "/usr/share/recoll/filters/msodump.zip/src/pptstream.py", line 67, in printDirectory
    obj.output()
  File "/usr/share/recoll/filters/msodump.zip/src/ole.py", line 601, in output
    self.__outputEntry(entry, debug)
  File "/usr/share/recoll/filters/msodump.zip/src/ole.py", line 669, in __outputEntry
    chain = satObj.getSectorIDChain(entry.StreamSectorID)
  File "/usr/share/recoll/filters/msodump.zip/src/ole.py", line 431, in getSectorIDChain
    nextID = self.array[initID]
IndexError: list index out of range

Local variables in innermost frame:
self: <ole.SSAT object at 0x212b290>
initID: 16777215
chain: [16777215]

Comment 1 Koen 2014-02-03 06:29:20 UTC
Created attachment 858385 [details]
File: backtrace

Comment 2 Koen 2014-02-03 06:29:22 UTC
Created attachment 858386 [details]
File: environ

Comment 3 Terje Røsten 2014-02-03 15:54:49 UTC
Thanks for your report.

Comment 4 Terje Røsten 2014-03-02 07:41:08 UTC
*** Bug 1064151 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2014-05-06 21:07:53 UTC
recoll-1.19.13-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/recoll-1.19.13-1.fc20

Comment 6 Fedora Update System 2014-05-06 21:08:18 UTC
recoll-1.19.13-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/recoll-1.19.13-1.fc19

Comment 7 Fedora Update System 2014-05-08 10:17:48 UTC
Package recoll-1.19.13-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing recoll-1.19.13-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6134/recoll-1.19.13-1.fc19
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-06-30 10:25:28 UTC
recoll-1.19.13-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-06-30 10:27:45 UTC
recoll-1.19.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.