Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060628 - Admin manage search page has an empty "Current Progress" section
Summary: Admin manage search page has an empty "Current Progress" section
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: development
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.3
Assignee: David Mason
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-03 05:41 UTC by Damian Jansen
Modified: 2014-03-20 05:47 UTC (History)
3 users (show)

Fixed In Version: 3.3.0-SNAPSHOT (20140218-0947)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 05:47:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1065790 None None None Never

Internal Links: 1065790

Description Damian Jansen 2014-02-03 05:41:59 UTC
Description of problem:
On the Manage Search page, there is an empty "Current Progress" section down the bottom. If th euser clicks "Perform Selected Actions" it shows a different page for the progress, so this sections seems unused.

Version-Release number of selected component (if applicable):
3.3.0 RC1

How reproducible:
Easy always

Steps to Reproduce:
1. Sign in as admin, click drop-down menu > Administration
2. Select Manage Search
3. Select some items. Note the "Current Progress" section"
4. Press Perform Selected Actions

Actual results:
A new screen with a progress bar

Expected results:
If it isn't supposed to show inline then the extra section is not necessary

Additional info:

Comment 1 David Mason 2014-02-13 02:25:23 UTC
Previously, the "Current Progress" section would have content that indicated either that no operations had been run since the last server restart, current progress of an operation, or the results of the last operation (success or failure). This seems to have been changed.

Technically this is all happening on the same page - the table is just hidden when the search is in progress. The fix should just be to hide the "Current Progress" heading when no action is in progress.

Comment 2 David Mason 2014-02-13 02:43:17 UTC
(In reply to David Mason from comment #1)
> Previously, the "Current Progress" section would have content that indicated
> either that no operations had been run since the last server restart,
> current progress of an operation, or the results of the last operation
> (success or failure). This seems to have been changed.
> 
> Technically this is all happening on the same page - the table is just
> hidden when the search is in progress. The fix should just be to hide the
> "Current Progress" heading when no action is in progress.

On inspection of the code, it looks like the information under "Current Progress" is still supposed to be displayed, but is not being rendered.

Comment 3 David Mason 2014-02-17 00:56:20 UTC
I have updated the display for reindexing status to be compatible with JSF 2 so that status is displayed.

Elapsed time and time estimates are not being displayed pending pending some backend changes. I will track this separately in https://bugzilla.redhat.com/show_bug.cgi?id=1065790


See: https://github.com/zanata/zanata-server/commit/e8147cdb0c2b0b42263a21602f8e02bfb6872b03

Comment 4 Sean Flanigan 2014-02-18 02:13:01 UTC
Which pull request was this?

And should we set target release to 3.3?

Comment 5 David Mason 2014-02-18 02:30:36 UTC
https://github.com/zanata/zanata-server/pull/378

Comment 6 Damian Jansen 2014-02-19 00:15:55 UTC
Verified at 1bf60cc19d6941929f586c3e8d62390fbb41644d

Comment 7 Sean Flanigan 2014-03-20 05:47:12 UTC
Closing VERIFIED bugs for Zanata server 3.3.2.


Note You need to log in before you can comment on or make changes to this bug.