Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060593 - The 'date' command's man page does not mention the --iso-8601 option.
Summary: The 'date' command's man page does not mention the --iso-8601 option.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coreutils
Version: 6.5
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-02 23:33 UTC by Jon McKenzie
Modified: 2014-02-03 18:16 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-03 18:16:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jon McKenzie 2014-02-02 23:33:56 UTC
Description of problem:

The 'date' man page does not mention the --iso-8601 option, which prints a date/timestamp in ISO-8601 format. The Texinfo manual does mention the option.

This option is important for things like AWS command-line tools, which expect an ISO-8601 timestamp for specifying dates. 

Version-Release number of selected component (if applicable):

coreutils-8.4-31

How reproducible:

Always

Steps to Reproduce:
1. Run the following command: "man date | grep iso-8601". No output is returned.
2. Use the --iso-8601 option at the command line: "date --iso-8601=seconds". This returns the requested timestamp in ISO-8601 format.

Actual results:

The man page should contain a description of the --iso-8601 option and arguments.

Expected results:

No such description exists.

Comment 2 Ondrej Vasik 2014-02-03 18:16:22 UTC
This is intentional, as the option "--iso-8601" is marked deprecated in the RHEL-6 source code. Actually, I don't see that option listed even in info manual (it is not mentioned in date options, only in one forgotten place as example in getdate.texi). Primary reason for is that this option is not working properly - see http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7444 as upstream report.
It was later reinstated (no longer deprecated) based on the gnulib fix of getdate.y parser by http://git.savannah.gnu.org/cgit/coreutils.git/commit/src/date.c?id=2f1384b7e4674f2bdf4c471eee050bece59e01e6 and http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=commitdiff;h=c2ecbc9a8262595b27f741e41375d06213a30fb6 .

Based on this explanation, I'm marking this not a bug, if you rely on this functionality in production, file RFE request against our product support (as the ISO format is not supported in RHEL-6 date atm.)


Note You need to log in before you can comment on or make changes to this bug.