Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060576 - RFE: on multiple disk installs, always create bootloader partitions on all selected devices
Summary: RFE: on multiple disk installs, always create bootloader partitions on all se...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-02 19:13 UTC by Chris Murphy
Modified: 2015-04-15 13:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 20:20:02 UTC


Attachments (Terms of Use)

Description Chris Murphy 2014-02-02 19:13:04 UTC
Description of problem:
On UEFI, anaconda has no way of permitting creation of an EFI System Partition per physical device chosen. Only one device gets an ESP, and it alone is mounted at /boot/efi. It's easy to do this on BIOS/MBR configurations, since grub is installed to each disk's MBR gap.


Version-Release number of selected component (if applicable):
anaconda

How reproducible:
Always

Steps to Reproduce:
1. Custom partitioning only permits creation of one ESP on one disk because only one /boot/efi can be created.


Actual results:
Only one disk can have an ESP, if that disk fails, we can't boot. 

This works correctly and seamless to the user on BIOS/MBR setups. It can be done manually with multiple BIOSBoots on BIOS/GPT (inelegant, non-obvious, but it's doable).


Expected results:

Each disk should get an ESP, so that we can always boot in case of a disk failure.


Additional info:
Related to bug 1022316. These required partitions should simply be created for the user, even when they use custom partitioning.

Comment 1 Chris Murphy 2014-03-20 17:17:57 UTC
This is the multiple device version of bug 1022316.

Comment 2 David Shea 2015-04-14 20:20:02 UTC
/boot/efi on RAID1 works fine and can be created with custom partitioning. Doing this automatically doesn't make sense since the rest of a RAID setup isn't automatic either.

Comment 3 Chris Murphy 2015-04-15 00:23:15 UTC
It's non-standard and incompatible with multiboot (including dual-boot). The firmware can write to the ESP and thereby make the md members inconsistent with each other in a way that md can't resolve.

There are two ways to do this consistent with the UEFI spec: 

1. sync the fedora directory on each ESP at install time, and grubby/new-kernel-pkg need to stop modifying the ESP and revert to making changes to /boot like with BIOS systems.

2. narrow the supportable hardware strictly to that which supports firmware RAID.

I also think it's dishonest to say this is notabug. The current design is flawed/bad hack, if it's going to stay this way it should be wontfix.


Note You need to log in before you can comment on or make changes to this bug.