Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060545 - [RFE] Spice proxy address missing validation.
Summary: [RFE] Spice proxy address missing validation.
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ---
: ---
Assignee: nobody nobody
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-02 14:33 UTC by Ilanit Stein
Modified: 2017-03-13 07:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-13 07:50:21 UTC
oVirt Team: Infra
ylavi: ovirt-future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Ilanit Stein 2014-02-02 14:33:41 UTC
Description of problem:

There is no form validation for the spice proxy address, defined via:
1. engine-config -s SpiceProxyDefault="..."
2. webadmin: cluster->console: Define SPICE proxy for Cluster
3. webadmin: pool->console: Define SPICE proxy for Cluster

Any string is accepted.

Version-Release number of selected component (if applicable):
ovirt-3.4.0-alpha2

Expected results:
According to spice feature doc (http://www.ovirt.org/Features/Spice_Proxy)
"The proxy has to follow the following form: [protocol://]<host>[:port]"

Comment 3 Yaniv Kaul 2017-03-13 07:50:21 UTC
There's little validation done in many fields - this is no exception.
Closing for the time being.


Note You need to log in before you can comment on or make changes to this bug.