Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060453 - [abrt] system-config-printer: authconn.py:240:_authloop:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)
Summary: [abrt] system-config-printer: authconn.py:240:_authloop:UnicodeDecodeError: '...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:33e3c9592b1e0a40fe95b5ee38b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-01 21:25 UTC by Michal Ambroz
Modified: 2014-11-17 06:32 UTC (History)
2 users (show)

Fixed In Version: system-config-printer-1.5.4-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-15 09:20:00 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-02-01 21:25 UTC, Michal Ambroz
no flags Details
File: environ (deleted)
2014-02-01 21:25 UTC, Michal Ambroz
no flags Details

Description Michal Ambroz 2014-02-01 21:25:44 UTC
Version-Release number of selected component:
system-config-printer-1.4.3-2.fc20

Additional info:
reporter:       libreport-2.1.11
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
dso_list:       system-config-printer-libs-1.4.3-2.fc20.noarch
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.12.7-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
authconn.py:240:_authloop:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/jobviewer.py", line 1080, in auth_info_dialog_response
    c.authenticateJob (jobid, auth_info)
  File "/usr/share/system-config-printer/authconn.py", line 222, in <lambda>
    return lambda *args, **kwds: self._authloop (fname, fn, *args, **kwds)
  File "/usr/share/system-config-printer/authconn.py", line 240, in _authloop
    result = fn.__call__ (*args, **kwds)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)

Local variables in innermost frame:
c: <cupspk.Connection instance at 0x2072dd0>
retry: False
kwds: {}
self: <authconn.Connection instance at 0x2072d88>
args: (77, ['mambroz', 'xAch\xc3\xbd\xc5\xbe+=exNewotn'])
fname: 'authenticateJob'
fn: <method-wrapper '__call__' of builtin_function_or_method object at 0x2072e18>

Comment 1 Michal Ambroz 2014-02-01 21:25:49 UTC
Created attachment 858130 [details]
File: backtrace

Comment 2 Michal Ambroz 2014-02-01 21:25:51 UTC
Created attachment 858131 [details]
File: environ

Comment 3 Jiri Popelka 2014-02-04 14:45:37 UTC
I can reproduce it with
python-cups-1.9.63-4.fc20 but not with
python-cups-1.9.66-1.fc21 so one of the 'python 3 compatibility' fixes must have already fixed it.

We probably won't push python-cups-1.9.66 into F20 as there's been a lot of changes, but you can Michal test it if you want.
Either 'yum --enablerepo=rawhide update python-cups' or
https://koji.fedoraproject.org/koji/buildinfo?buildID=481163

Comment 5 Fedora Update System 2014-11-10 18:07:04 UTC
system-config-printer-1.5.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/system-config-printer-1.5.4-1.fc21

Comment 6 Fedora Update System 2014-11-10 18:46:16 UTC
system-config-printer-1.4.7-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.7-1.fc20

Comment 7 Fedora Update System 2014-11-12 02:40:22 UTC
Package system-config-printer-1.5.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.5.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14750/system-config-printer-1.5.4-1.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-11-15 09:20:00 UTC
system-config-printer-1.4.7-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-11-17 06:32:54 UTC
system-config-printer-1.5.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.