Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060410 - engine.log - Failed to invoke scheduled method refreshAllUsers (every 1hr or reboot)
Summary: engine.log - Failed to invoke scheduled method refreshAllUsers (every 1hr or ...
Keywords:
Status: CLOSED DUPLICATE of bug 1063276
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Martin Perina
QA Contact: bugs@ovirt.org
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-01 10:35 UTC by Pavel Stehlik
Modified: 2014-02-11 12:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-11 12:44:35 UTC
oVirt Team: ---


Attachments (Terms of Use)
engine-refreshAllUsers.tgz (deleted)
2014-02-01 10:35 UTC, Pavel Stehlik
no flags Details

Description Pavel Stehlik 2014-02-01 10:35:35 UTC
Created attachment 858070 [details]
engine-refreshAllUsers.tgz

Description of problem:
 Although searching for users works (& login via only added domain as well), there is still periodical message in engine.log. Every hour or after restart service. Debug log attached. Att also contains manage-domain.log

...
2014-02-01 11:03:38,191 ERROR [org.ovirt.engine.core.utils.timer.SchedulerUtilQuartzImpl] (DefaultQuartzScheduler_Worker-1) Failed to invoke scheduled method refreshAllUsers: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_51]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_51]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_51]
        at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_51]
        at org.ovirt.engine.core.utils.timer.JobWrapper.execute(JobWrapper.java:60) [scheduler.jar:]
        at org.quartz.core.JobRunShell.run(JobRunShell.java:213) [quartz.jar:]
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557) [quartz.jar:]
Caused by: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.DbUserCacheManager.refreshUser(DbUserCacheManager.java:220) [bll.jar:]
        at org.ovirt.engine.core.bll.DbUserCacheManager.refreshUsers(DbUserCacheManager.java:137) [bll.jar:]
        at org.ovirt.engine.core.bll.DbUserCacheManager.refreshAllUsers(DbUserCacheManager.java:92) [bll.jar:]
        ... 7 more


Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.5.beta1.el6.noarch

How reproducible:


Steps to Reproduce:
1. use engine-manage-domains and add AD domain
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Martin Perina 2014-02-11 12:44:35 UTC

*** This bug has been marked as a duplicate of bug 1063276 ***


Note You need to log in before you can comment on or make changes to this bug.