Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060269 - reverse DNS lookup on master domain server reload
Summary: reverse DNS lookup on master domain server reload
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Server
Version: 6.2.0,6.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR1
: EAP 6.3.0
Assignee: Jason Greene
QA Contact: Petr Kremensky
URL:
Whiteboard:
: 1060271 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-31 15:58 UTC by Aleksandar Kostadinov
Modified: 2014-08-20 10:21 UTC (History)
5 users (show)

Doc Type: Bug Fix
Doc Text:
Users of previous versions of JBoss EAP 6 may have found that servers were not able to reconnect to the Domain Controller after it was reloaded, if the managed servers were not restarted as well. This issue occurred if the reverse IP lookup was incorrectly configured, meaning the servers were presented with the hostname of the Controller (and not its IP address) to reconnect to. In these situations the connection would fail. This issue has been resolved in this release of the product by reusing the data stored in the `InetSocket` object. This avoids the need to do a reverse IP lookup and allows the servers to reconnect as expected.
Clone Of:
: 1060271 (view as bug list)
Environment:
Last Closed: 2014-06-28 15:39:40 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1043768 None None None Never

Internal Links: 1043768

Description Aleksandar Kostadinov 2014-01-31 15:58:17 UTC
This is a clone of https://issues.jboss.org/browse/WFLY-2785

It is to avoid doing DNS reverse lookup when reconnecting to server but use whatever we already have as a value in InetSocket object. Otherwise user may face problem when reverse IP resolution is not configured or configured improperly.
This also caused some problems running the testsuite on windows.

Comment 2 Russell Dickenson 2014-02-03 05:35:48 UTC
Is this ticket relevant to the JBoss EAP 6.2.1 Release Notes? If so, please mark it as such and provide draft text. I understand that it's currently at "New" status but as GA is February 5, I presume it's either already completed, or to be deferred until next CP.

Comment 4 Carlo de Wolf 2014-02-03 14:57:50 UTC
*** Bug 1060271 has been marked as a duplicate of this bug. ***

Comment 5 Kabir Khan 2014-02-15 09:33:18 UTC
https://github.com/jbossas/jboss-eap/pull/915 replaces 870

Comment 6 Petr Kremensky 2014-03-03 13:56:37 UTC
Verified on EAP 6.3.0.DR1.


Note You need to log in before you can comment on or make changes to this bug.