Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060216 - RELNOTES - document gpodder user data migration process
Summary: RELNOTES - document gpodder user data migration process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: release-notes
Version: devel
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Travis
QA Contact: Fedora Docs QA
URL:
Whiteboard:
Depends On:
Blocks: fc5-relnotes-traqr
TreeView+ depends on / blocked
 
Reported: 2014-01-31 13:34 UTC by Gwyn Ciesla
Modified: 2015-03-05 23:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 23:51:26 UTC


Attachments (Terms of Use)

Description Gwyn Ciesla 2014-01-31 13:34:44 UTC
gpodder is being upgraded from 2.20.3 to 3.5.2.  There is a configuration and date storage change between these versions.  After upgrading the RPM, any user on the system who uses gpodder, prior to opening it, should run /usr/bin/gpodder-migrate2tres, which will migrate the user's data and configuration to the new format, including all subscribed feeds and downloaded podcasts.

Comment 1 Pete Travis 2014-01-31 16:07:08 UTC
Thanks for the report, Jon!

I'll do some research, but while we're here, do you know any recourse for users who opened gpodder without doing the migration first?

Comment 2 Gwyn Ciesla 2014-01-31 16:16:57 UTC
Yes, in fact I discovered that the hard way, after opening it to nothing, and trying to import from the old settings in ~/gpodder-downloads. :) 

Just remove ~/gPodder and run usr/bin/gpodder-migrate2tres.

Comment 3 Gwyn Ciesla 2014-03-03 13:49:24 UTC
FYI, the new version is now 3.6.0, but no changes to the above are needed.

Comment 4 Gwyn Ciesla 2014-03-17 14:56:54 UTC
FYI, the new version is now 3.6.1, but no changes to the above are needed.

Comment 5 Gwyn Ciesla 2014-06-02 16:56:54 UTC
FYI, the new version is now 3.7.0, but no changes to the above are needed.

Comment 6 Gwyn Ciesla 2014-07-30 16:38:52 UTC
FYI, the new version is now 3.8.0, but no changes to the above are needed.

Comment 8 Gwyn Ciesla 2014-10-29 17:21:31 UTC
FYI, the new version is now 3.8.2, but no changes to the above are needed.

Comment 9 Gwyn Ciesla 2014-11-21 14:23:41 UTC
FYI, the new version is now 3.8.3, but no changes to the above are needed.

Comment 10 Pete Travis 2015-03-05 23:51:26 UTC
This is done. Thanks again, Jon.


Note You need to log in before you can comment on or make changes to this bug.