Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060189 - [abrt] firewalld: service.py:30:<module>:ImportError: No module named six
Summary: [abrt] firewalld: service.py:30:<module>:ImportError: No module named six
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:46f945b60638f5695ce95952a00...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-31 11:53 UTC by Anton Ohorodnyk
Modified: 2014-01-31 12:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-31 12:57:34 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-01-31 11:53 UTC, Anton Ohorodnyk
no flags Details
File: environ (deleted)
2014-01-31 11:53 UTC, Anton Ohorodnyk
no flags Details

Description Anton Ohorodnyk 2014-01-31 11:53:15 UTC
Version-Release number of selected component:
firewalld-0.3.9.2-1.fc20

Additional info:
reporter:       libreport-2.1.11
cmdline:        /usr/bin/python -Es /usr/sbin/firewalld --nofork --nopid
dso_list:       python-slip-dbus-0.6.0-1.fc20.noarch
executable:     /usr/sbin/firewalld
kernel:         3.12.8-300.fc20.x86_64
runlevel:       unknown
type:           Python
uid:            0

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/slip/dbus/service.py:30
#2 <module> in /usr/lib/python2.7/site-packages/slip/dbus/__init__.py:8
#3 <module> in /usr/lib/python2.7/site-packages/firewall/server/server.py:38
#4 <module> in /usr/sbin/firewalld:132

Comment 1 Anton Ohorodnyk 2014-01-31 11:53:18 UTC
Created attachment 857809 [details]
File: backtrace

Comment 2 Anton Ohorodnyk 2014-01-31 11:53:20 UTC
Created attachment 857810 [details]
File: environ

Comment 3 Jiri Popelka 2014-01-31 12:20:33 UTC
There seems to be some problem with python-six package on your system.
Please reinstall it with 'yum reinstall python-six' and show me output of the following command:
rpm -V python-six python-slip-dbus

note: python-six is required by python-slip-dbus which is required by firewalld.

Comment 4 Anton Ohorodnyk 2014-01-31 12:28:13 UTC
before reinstall python-slip-dbus, but after reinstall python-six

$ rpm -V python-six python-slip-dbus
missing     /usr/lib/python2.7/site-packages/slip.dbus-0.6.0-py2.7.egg-info
$

after reinstall python-slip-dbus and python-six
$ rpm -V python-six python-slip-dbus
$

Comment 5 Jiri Popelka 2014-01-31 12:57:34 UTC
Thanks. I'm closing this ticket as I hope it should be ok now. Feel free to reopen if you reproduce it.


Note You need to log in before you can comment on or make changes to this bug.