Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060166 - DNF hangs RPM file installation if there are troubles with 3rd party repos
Summary: DNF hangs RPM file installation if there are troubles with 3rd party repos
Keywords:
Status: CLOSED DUPLICATE of bug 1056400
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-31 11:08 UTC by Germano Massullo
Modified: 2014-01-31 12:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-31 12:13:46 UTC


Attachments (Terms of Use)

Description Germano Massullo 2014-01-31 11:08:39 UTC
Description of problem:
I tried to install RPM file downloaded from "Lightworks For Linux", by doing
# dnf install lwks-11.5-amd64.rpm
but I obtained error

Problem with repo 'steam': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.
Errore: Nothing to do.


DNF should not abort installation if there are troubles on 3rd party mirror. In this case the repo is the well known http://spot.fedorapeople.org/steam

Finally I used yum and the package has been installed without problems.

Version-Release number of selected component (if applicable):
dnf-0.4.12-1.fc20.noarch

Comment 1 Ales Kozumplik 2014-01-31 12:13:46 UTC
Hi, the error you see is not what stopped the installation as the repo was disabled thanks to its 'skip_if_unavailable=1' setting.

This is only another exhibition of the bug 1056400.

*** This bug has been marked as a duplicate of bug 1056400 ***


Note You need to log in before you can comment on or make changes to this bug.