Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1060051 - IBM JDK's XSL transformer behavior causes invalid config XMLs in some cases
Summary: IBM JDK's XSL transformer behavior causes invalid config XMLs in some cases
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite
Version: 6.2.0,6.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER9
: EAP 6.3.0
Assignee: Dominik Pospisil
QA Contact: Pavel Jelinek
URL:
Whiteboard:
: 1110625 (view as bug list)
Depends On:
Blocks: 1099440
TreeView+ depends on / blocked
 
Reported: 2014-01-31 09:55 UTC by Pavel Jelinek
Modified: 2014-09-05 10:39 UTC (History)
6 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
IBM JDK
Last Closed: 2014-08-06 14:34:18 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBQA-9029 Major Resolved IBM JDK's XSL transformer behavior causes invalid config XMLs in some cases 2017-05-18 09:16:34 UTC
JBoss Issue Tracker WFLY-3361 None None None Never

Description Pavel Jelinek 2014-01-31 09:55:48 UTC
eg. in IIOP module, standalone-full.xml of jbossas-iiop-client server config looks like this: 

<subsystem xmlns="urn:jboss:domain:jacorb:1.3">
    <orb socket-binding="jacorb" ssl-socket-binding="jacorb-ssl">
        <initializers xmlns="" security="client" transactions="on"/>
    </orb>
</subsystem>

The empty xmlns attribute (xmlns='') causes parsing exceptions and prevents server from starting. 

See: https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP-6.2.x-CP/job/eap-62x-patched-as-testsuite-RHEL-matrix-IBMJDK7/lastCompletedBuild/jdk=ibm17,label_exp=RHEL6%26%26x86/testReport/org.jboss.as.test.iiop.security/IIOPSecurityInvocationTestCase/org_jboss_as_test_iiop_security_IIOPSecurityInvocationTestCase/

Comment 1 Pavel Jelinek 2014-05-22 11:31:32 UTC
Currently affected modules: 
testsuite/integration/iiop
testsuite/integration/manualmode
testsuite/integration/multinode

Comment 2 Pavel Jelinek 2014-05-22 11:33:00 UTC
Dirty fix in Wildfly was merged: https://github.com/wildfly/wildfly/pull/6273

Comment 3 Carlo de Wolf 2014-06-02 10:35:32 UTC
Proper fix: https://github.com/wildfly/wildfly/pull/6303

Comment 4 Dominik Pospisil 2014-06-23 13:58:20 UTC
EAP PR: https://github.com/jbossas/jboss-eap/pull/1469

Comment 5 Pavel Jelinek 2014-07-11 10:27:31 UTC
Verified for EAP 6.3.0.ER9.

Comment 6 Dominik Pospisil 2014-09-05 10:39:04 UTC
*** Bug 1110625 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.