Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059893 - OVIRT-PYTHON-SDK Template object lacks 'sso' parameter that exists in api.xsd
Summary: OVIRT-PYTHON-SDK Template object lacks 'sso' parameter that exists in api.xsd
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-sdk
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.4.0
Assignee: Juan Hernández
QA Contact: Ilia Meerovich
URL:
Whiteboard: infra
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-01-30 20:47 UTC by Ilia Meerovich
Modified: 2016-07-05 00:06 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-sdk-python-3.4.0.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:23:10 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24646 None None None Never

Description Ilia Meerovich 2014-01-30 20:47:58 UTC
rpms:
ovirt-engine-3.4.0-0.5.beta1.el6.noarch
ovirt-engine-sdk-python-3.4.0.2-1.20140114.gitbaccf38.el6

Appears in api.xsd:

<xs:element ref="sso" minOccurs="0" maxOccurs="1"/>

doesn't appear in python sdk (and most probably doesn't appear in java sdk too)

Comment 1 Juan Hernández 2014-01-30 21:39:30 UTC
This property has been added after the latest refresh of the SDKs. It will be available in the next release.

Comment 2 Ilia Meerovich 2014-02-17 08:21:25 UTC
raising severity to urgent since it is tier 0 bug

Comment 3 Juan Hernández 2014-02-18 13:54:25 UTC
The packages containing the fix for this issue are available here:

http://jhernand.fedorapeople.org/rpms/ovirt-engine-sdk-python/3.4.0.4-1

Comment 4 Ilia Meerovich 2014-02-19 08:51:54 UTC
imeerovi@imeerovi ~/git/ART (RHEVM-979-dc-search) $ bpython
>>> from ovirtsdk.xml import params
>>> from ovirtsdk.api import API 
>>> api = API(url='https://ilia-rhevm.qa.lab.tlv.redhat.com:443', username='admin@internal', password='123456', insecure=True) 
>>> api.templates.list()[0]
<ovirtsdk.infrastructure.brokers.Template object at 0x2ed4110>
>>> template = api.templates.list()[0]
>>> template.get_sso()
<ovirtsdk.xml.params.Sso object at 0x2ed4d10>
>>> 
imeerovi@imeerovi ~/git/ART (RHEVM-979-dc-search) $ rpm -q ovirt-engine-sdk-python
ovirt-engine-sdk-python-3.4.0.4-1.el6.noarch

Comment 5 Sandro Bonazzola 2014-03-31 12:23:10 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.