Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059858 - Can not add phpmyadmin cartridge to gear running mysql-5.5 due to mysql-5.1 dependency
Summary: Can not add phpmyadmin cartridge to gear running mysql-5.5 due to mysql-5.1 d...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Management Console
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Clayton Coleman
QA Contact: libra bugs
URL:
Whiteboard:
: 1062947 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 19:45 UTC by Corey Daley
Modified: 2015-05-15 01:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-12 03:06:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Corey Daley 2014-01-30 19:45:36 UTC
Description of problem:
Users are not able to add the phpmyadmin cartridge to gears running mysql-5.5 because of a dependency on the mysql-5.1 cartridge

Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1.  Create gear and add mysql-5.5
2.  Try to add the phpmyadmin cartridge
3.

Actual results:
Won't work

Expected results:
should work

Additional info:
Works fine with the rhc command line tool

Comment 1 Clayton Coleman 2014-02-07 17:21:14 UTC
Going to fix this once and for all.

Comment 2 Clayton Coleman 2014-02-07 21:16:26 UTC
Fixed in https://github.com/openshift/li/pull/2349

Comment 3 openshift-github-bot 2014-02-08 18:18:51 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/91a23a8dff271f8811832ab1908db9f2cb0f83ec
Bug 1059858 - Expose requires via REST API

Decorate cartridges properly with requires

Comment 4 Dan McPherson 2014-02-09 05:54:02 UTC
*** Bug 1062947 has been marked as a duplicate of this bug. ***

Comment 5 netroby 2014-02-10 01:46:03 UTC
still could not add phpmyadmin, you guys need test it quickly. 
thanks.

Comment 6 Xiaoli Tian 2014-02-10 02:26:31 UTC
(In reply to netroby from comment #5)
> still could not add phpmyadmin, you guys need test it quickly. 
> thanks.

you could work around it by adding it via rhc for now before the fix is released.

Comment 7 Yujie Zhang 2014-02-10 02:47:27 UTC
Tested it on devenv_4352, the phpmyadmin can be added to mysql-5.5 now, so verify this bug, thanks.

Comment 8 eddie wong 2014-02-12 06:42:08 UTC
when will this fix aply to production?

Comment 9 eddie wong 2014-02-26 05:19:14 UTC
I found the fix is already commit to production.
It can add via web console.


Note You need to log in before you can comment on or make changes to this bug.