Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059850 - [abrt] speech-dispatcher-0.8-3.fc19: pthread_cancel: Process /usr/lib64/speech-dispatcher-modules/sd_festival was killed by signal 11 (SIGSEGV)
Summary: [abrt] speech-dispatcher-0.8-3.fc19: pthread_cancel: Process /usr/lib64/speec...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: speech-dispatcher
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:df6af9fd2da61402ad68d96bbe9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 19:40 UTC by Peque
Modified: 2015-03-31 21:40 UTC (History)
15 users (show)

Fixed In Version: speech-dispatcher-0.8.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of: 995639
Environment:
Last Closed: 2015-03-23 07:16:18 UTC


Attachments (Terms of Use)

Description Peque 2014-01-30 19:40:09 UTC
+++ This bug was initially created as a clone of Bug #995639 +++

Description of problem:
I have speech-dispatcherd.service configured to always start at system boot. As I started the system, a message appeared, stating at the daemon had failed  to start and that I should check systemctl status speech-dispatcherd.serice. I did so and learned what I already knew, that the daemon was not running, so I started it manually by issuing, as root, systemctl start speech-dispatcherd.service. After doing so, this error was generated and I opted to report it.

Version-Release number of selected component:
speech-dispatcher-0.8-3.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/lib64/speech-dispatcher-modules/sd_festival /etc/speech-dispatcher/modules/festival.conf
crash_function: pthread_cancel
executable:     /usr/lib64/speech-dispatcher-modules/sd_festival
kernel:         3.10.5-201.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (3 frames)
 #0 pthread_cancel at pthread_cancel.c:34
 #1 module_terminate_thread at module_utils.c:826
 #2 module_close at festival.c:472

--- Additional comment from Peter Gückel on 2013-08-09 19:07:57 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:07:59 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:02 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:04 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:07 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:09 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:11 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:14 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:16 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:19 EDT ---



--- Additional comment from Peter Gückel on 2013-08-09 19:08:21 EDT ---



--- Additional comment from Igor Gnatenko on 2013-09-10 13:28:00 EDT ---

Have this problem too.

--- Additional comment from Victor Costan on 2013-09-26 06:32:47 EDT ---

Got this issue by trying to launch Orca on a freshly updated Fedora 20 installation.

--- Additional comment from Alexander Todorov on 2013-10-10 06:49:13 EDT ---

Same for me on the latest Fedora 20 from today. 

Following this test case:
https://fedoraproject.org/wiki/QA:Testcase_Gnome_Accessibility

I just turned On/Off the Screen Reader setting and a while later ABRT popped up.

--- Additional comment from Wellington Poi on 2013-10-10 13:17:22 EDT ---

I got the same error here while activating the screen reader.

Package speech-dispatcher-0.8-5.fc20.x86_64

Fedora 20

--- Additional comment from Peter Gückel on 2013-10-23 10:44:49 EDT ---

This has not yet been resolved.

--- Additional comment from Matthias Clasen on 2013-11-01 23:03:34 EDT ---

I believe what is happening here is that the festival 'module' subprocess is segfaulting, and that is causing systemd to think the service has failed.

If you start speech-dispatcher on the commandline, like this:

/usr/bin/speech-dispatcher -d

it happily starts up, and all the other modules end up running:

$ ps ax | grep speech
23349 pts/2    Sl     0:00 /usr/lib64/speech-dispatcher-modules/sd_dummy /etc/speech-dispatcher/modules/dummy.conf
23352 pts/2    Sl     0:00 /usr/lib64/speech-dispatcher-modules/sd_generic /etc/speech-dispatcher/modules/generic.conf
23355 pts/2    Sl     0:00 /usr/lib64/speech-dispatcher-modules/sd_flite /etc/speech-dispatcher/modules/flite.conf
23360 pts/2    Sl     0:00 /usr/lib64/speech-dispatcher-modules/sd_espeak /etc/speech-dispatcher/modules/espeak.conf
23365 pts/2    Sl     0:00 /usr/lib64/speech-dispatcher-modules/sd_cicero /etc/speech-dispatcher/modules/cicero.conf
23369 ?        Ssl    0:00 /usr/bin/speech-dispatcher -d

This includes the flite module, which is also for festival - maybe we just need to stop shipping the faulty festival module ?

--- Additional comment from Peter Gückel on 2013-11-03 10:30:04 EST ---

I disabled the festival module and enabled the flite module in speakd.conf. I started jovie and had speech immediately. I don't know which module was speaking, espeak or flite, but there was speech without any messing around.

The festival module does appear to be the problem.

Curiously, when I run ps ax | grep speech, I get:

4050 ?        Ssl    0:00 /usr/bin/speech-dispatcher -d
4056 pts/1    S+     0:00 grep --color=auto speech

The modules are not shown, as in Comment 17.

--- Additional comment from Mikhail on 2013-11-08 00:05:04 EST ---

Demonstration: https://drive.google.com/file/d/0B0nwzlfiB4aQNmtPVFdIR2FKLWM/edit?usp=sharing

--- Additional comment from Adam Williamson on 2013-11-26 19:21:22 EST ---

Still happens on first launch of Orca in a clean F20 Final TC2+ (my pre-TC3 smoketest live image) install, but Orca does actually run and work.

--- Additional comment from Rudd-O DragonFear on 2013-12-09 23:43:01 EST ---

All those stupid modules **should not be running to begin with** if they haven't been configured to run, each module is establishing a connection to PulseAudio and keeping it open even when they are quiet, which is completely ruining my digital out.   This is making me so angry.

--- Additional comment from Peter Robinson on 2013-12-10 04:13:12 EST ---

(In reply to Rudd-O DragonFear from comment #21)
> All those stupid modules **should not be running to begin with** if they
> haven't been configured to run, each module is establishing a connection to
> PulseAudio and keeping it open even when they are quiet, which is completely
> ruining my digital out.   This is making me so angry.

And how is a blind person suppose to be able to use the computer by default if the primary means of them navigating is disabled by default? It's not all about you and I'm sure you, as someone who appears to be an able bodied person, are more than capable of disabling it if you don't need it.

This is off topic for the bug.

--- Additional comment from Adam Williamson on 2013-12-12 06:54:54 EST ---

same bug happens when you run KDE's screen reader thingy too, FWIW - it's called 'Jovie' (because, I don't know, I guess GNOME doesn't have a monopoly on completely cryptic names for screen readers).

--- Additional comment from Jason Farrell on 2013-12-18 00:57:30 EST ---

Ran into this when using the "Checker Plus for Gmail" Chrome extension, when it tries to read incoming email.

--- Additional comment from  on 2013-12-18 08:50:33 EST ---

Confirmed with F20.

I just surf in the Internet with epiphany and Orca enabled.

--- Additional comment from  on 2013-12-18 09:12:34 EST ---

For me this happens realy often and make normal work nearby impossible :/ (because often orca can not speak anymore).

--- Additional comment from Rudd-O DragonFear on 2013-12-19 00:25:35 EST ---

ONLY the DEFAULT module, and perhaps other activated modules needs to be running.

I never thought my comment on running many, non-configured, modules would be spun into hatred for blind people.  Thanks for that!

--- Additional comment from Peque on 2014-01-01 11:22:04 EST ---

Got this crash today in Fedora 20 when I launched Mumble (package "mumble" from the fedora repos). ABRT told me it was already reported here.

I was also listening to some music and the music stopped playing, until I closed Mumble (that may be another problem).

--- Additional comment from Michael Schwendt on 2014-01-19 15:38:49 EST ---

Got this crash today in F20 when testing GNOME Shell > Universal Access > Screen Reader -> ON.

$ rpm -qa speech\*
speech-dispatcher-0.8-5.fc20.x86_64

Comment 1 Peque 2014-01-30 19:42:27 UTC
Just changed version to 20, as this bug is affecting Fedora 20.

Comment 2 Fedora Update System 2015-03-20 15:06:28 UTC
speech-dispatcher-0.8.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8.2-1.fc20

Comment 3 Fedora Update System 2015-03-20 15:06:45 UTC
speech-dispatcher-0.8.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8.2-1.fc21

Comment 4 Fedora Update System 2015-03-20 15:06:56 UTC
speech-dispatcher-0.8.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8.2-1.fc22

Comment 5 Fedora Update System 2015-03-22 04:28:23 UTC
Package speech-dispatcher-0.8.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing speech-dispatcher-0.8.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4357/speech-dispatcher-0.8.2-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-03-23 07:16:18 UTC
speech-dispatcher-0.8.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-03-31 21:39:42 UTC
speech-dispatcher-0.8.2-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2015-03-31 21:40:59 UTC
speech-dispatcher-0.8.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.