Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059801 - You can't save a compressed file unless it is expressly typed in the Name field of the "Save As" dialog box
Summary: You can't save a compressed file unless it is expressly typed in the Name fie...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gimp
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 16:58 UTC by Bill Sanford
Modified: 2017-02-07 12:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 12:22:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bill Sanford 2014-01-30 16:58:32 UTC
Description of problem:
Using GIMP 2.8, I have an image that I want to save as a compressed file. So using the File -> Saves As, I select the gzip archive option and type the file name in the "Name" field without the extension of the file name. The file gets saved as a *.xcf file without compression.

If I type a new name of the file *with* the file extension and select the gzip archive option, only then it will save the image as a compressed file.

If you try and overwrite the saved .xcf file using the file name and the extension using the gzip archive option, this fails.

For example,

File -> Save As -> Filename - "test" with gzip archive option selected, this is saved as test.xcf, without compression - Fail

File -> Save As -> Filename - "test1.xcf.gz" with gzip archive option selected, this is saved as test1.xcf.gz - with compression - Pass

File -> Save As -> Filename "test.xcf.gz" with gzip archive option selected (And test.xcf already existing), this is saved as test.xcf (Without compression) - Fail because test.xcf wasn't overwritten as a compressed file or ideally saved as different file name of test.xcf.gz.

Version-Release number of selected component (if applicable):
RHEL-7.0-20140127.0
gimp-2.8.10-4

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.

Actual results:
See above 

Expected results:
See above 

Additional info:

Maureen Duffy was showing me GIMP for testing purposes and she saw this behavior.

Comment 1 Nils Philippsen 2014-02-11 10:49:35 UTC
(In reply to Bill Sanford from comment #0)
> Description of problem:
> Using GIMP 2.8, I have an image that I want to save as a compressed file. So
> using the File -> Saves As, I select the gzip archive option and type the
> file name in the "Name" field without the extension of the file name. The
> file gets saved as a *.xcf file without compression.
> 
> If I type a new name of the file *with* the file extension and select the
> gzip archive option, only then it will save the image as a compressed file.
> 
> If you try and overwrite the saved .xcf file using the file name and the
> extension using the gzip archive option, this fails.

I can't reproduce the problem here (Fedora 20 and RHEL 7).

> For example,
> 
> File -> Save As -> Filename - "test" with gzip archive option selected, this
> is saved as test.xcf, without compression - Fail
> 
> File -> Save As -> Filename - "test1.xcf.gz" with gzip archive option
> selected, this is saved as test1.xcf.gz - with compression - Pass
> 
> File -> Save As -> Filename "test.xcf.gz" with gzip archive option selected
> (And test.xcf already existing), this is saved as test.xcf (Without
> compression) - Fail because test.xcf wasn't overwritten as a compressed file
> or ideally saved as different file name of test.xcf.gz.

My tests yield the following (all with gzip archive option selected)

- "test": when clicking on "Save", "test" becomes visibly expanded to "test.xcf.gz" and saved (compressed with gzip)
- "test1.xcf.gz": gets saved under that name (compressed with gzip)
- "test.xcf.gz" with existing "test.xcf": gets saved as "test.xcf.gz" (compressed with gzip), "test.xcf" isn't touched

--> everything worked as I expected it.

> Version-Release number of selected component (if applicable):
> RHEL-7.0-20140127.0
> gimp-2.8.10-4

Umm, no?

The latest version available for RHEL-7 is 2.8.10-3.el7, the last functional change was in 2.8.10-1.el7 (-2.el7 and -3.el7 were from the mass rebuilds). I've tested this with -2.el7 on a RHEL-7 VM (-3.el7 is being installed as part of a huge update which I'm running now, but I doubt that'll make a difference) and with -4.fc20 on Fedora 20. Which version were you using?

Comment 5 Máirín Duffy 2014-02-19 00:36:41 UTC
Hi Nils, sorry I missed you in IRC, I was in a meeting. I can reproduce this as Bill describes on Fedora 20 in gimp-2.8.10-4.fc20.x86_64. I followed Bill's steps exactly and I get the same results he did.

Comment 8 Josef Ridky 2017-02-07 12:22:50 UTC
Hi,

I have tested this bug report against actual gimp package in RHEL 7 (gimp-2.8.16-3.el7) and reported gimp version in RHEL (gimp-2.8.10-3.el7).

From comment #0:

> File -> Save As -> Filename - "test" with gzip archive option selected, 
> this is saved as test.xcf, without compression - Fail

In my case it is saved as test.xcf.gz (in both versions) - Pass

> File -> Save As -> Filename - "test1.xcf.gz" with gzip archive 
> option selected, this is saved as test1.xcf.gz - with compression - Pass

In my case it is saved as test1.xcf.gz (in both versions) - Pass

> File -> Save As -> Filename "test.xcf.gz" with gzip archive option selected 
> (And test.xcf already existing), this is saved as test.xcf 
> (Without compression) - Fail because test.xcf wasn't overwritten as 
> a compressed file or ideally saved as different file name of test.xcf.gz.

In my case it is saved as test.xcf.gz and I have been asked, if I wish to overwrite the old file (in both versions) - Pass

What can be probably misunderstand (or at least I haven't found it in this bug thread) if you want to save some image in "Save as" window at specific format, you should choose the format in table at the bottom of window (under "Select File Type (By Extension)" label - probably will be necessary to click on this label to see that table). Types presented in select box (under Preview box) are used just to filter files in box with available files.

Because of results from my test cases I am closing this bugzilla as WORKSFORME.

Feel free to reopen this bugzilla in case, that described problems still persist.


Note You need to log in before you can comment on or make changes to this bug.