Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059798 - [RFE] Logout mechanism for OpenShift Console and Session Timeout configuration
Summary: [RFE] Logout mechanism for OpenShift Console and Session Timeout configuration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.0.0
Hardware: All
OS: All
high
high
Target Milestone: ---
: ---
Assignee: Mike Barrett
QA Contact:
URL:
Whiteboard:
: 1035472 1086114 (view as bug list)
Depends On:
Blocks: 1021658 1086114
TreeView+ depends on / blocked
 
Reported: 2014-01-30 16:52 UTC by Ricardo Martinelli de Oliveira
Modified: 2019-04-16 14:07 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-18 12:46:07 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 443553 None None None Never
Red Hat Knowledge Base (Solution) 447263 None None None 2018-12-03 20:49:32 UTC

Comment 2 Luke Meyer 2014-01-30 23:08:04 UTC
Bug 1035472 exists for OSE 1.2.
https://trello.com/c/CILtbHLX/142-mgmt-console-cookie-based-auth-and-logout-enterprise exists on the public trello.

Comment 4 Brenton Leanhardt 2014-02-04 19:19:36 UTC
*** Bug 1035472 has been marked as a duplicate of this bug. ***

Comment 12 Luke Meyer 2014-04-10 14:28:27 UTC
*** Bug 1086114 has been marked as a duplicate of this bug. ***

Comment 14 Luke Meyer 2014-06-03 13:04:57 UTC
One simpler workaround that will work in many browsers: add the username into the url. E.g., if the URL is https://openshift.example.com/console, add the username like so:

https://username@openshift.example.com/console

In many browsers this will prompt to re-enter authentication. In fact an early workaround used something like this as a link to "log out". It just wasn't reliable in all browsers.

It's not an enterprise solution, by any means, but I mention it here in the hopes it will help some.

Comment 15 August Simonelli 2014-06-03 23:47:20 UTC
I've given that a try in Chrome on OSX and the results are a bit rough. I'm getting multiple prompts etc. But works well in Mozilla on OSX though. Appreciate the note Luke - it is helpful to have some options.

Comment 22 Brenton Leanhardt 2015-08-18 12:46:07 UTC
This was resolved by OpenShift Enterprise 3.0.


Note You need to log in before you can comment on or make changes to this bug.