Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059780 - [oVirt] NPE in update vm/template
Summary: [oVirt] NPE in update vm/template
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-api
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: gustavo.pedrosa
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
: 1058078 1062965 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 16:08 UTC by gustavo.pedrosa
Modified: 2014-12-15 12:46 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:33:11 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23067 None None None Never
oVirt gerrit 23859 None None None Never

Description gustavo.pedrosa 2014-01-30 16:08:55 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 gustavo.pedrosa 2014-01-30 16:18:41 UTC
Description of problem:
Boolean null is casted to boolean in update vm/template (via rest)

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4

How reproducible:
100%

Steps to Reproduce:
1. Try update vm/template (via rest)
2.
3.

Actual results:
NPE

Expected results:
Update with success

Additional info:

Comment 2 Michal Skrivanek 2014-02-03 15:10:55 UTC
*** Bug 1058078 has been marked as a duplicate of this bug. ***

Comment 3 Omer Frenkel 2014-02-10 08:30:51 UTC
*** Bug 1062965 has been marked as a duplicate of this bug. ***

Comment 4 Ilanit Stein 2014-02-17 09:06:02 UTC
Verified on ovirt-engine-3.4.0-0.7.beta2.el6.noarch.

http://jenkins.qa.lab.tlv.redhat.com:8080/view/Compute/view/3.4-git/view/Virt/job/3.4-git-compute-virt-reg_vms-rest-nfs/22/
note: Test fail on other bugs. All update VM cases, which had failed before, is passing in this build.

Comment 5 Sandro Bonazzola 2014-03-31 12:33:11 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.