Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059768 - [engine] disconnectStorageServer is sent *before* disconnectStoragePool hosts during remove datacenter flow
Summary: [engine] disconnectStorageServer is sent *before* disconnectStoragePool hosts...
Keywords:
Status: CLOSED DUPLICATE of bug 1059769
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Liron Aravot
QA Contact: bugs@ovirt.org
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 15:35 UTC by Gadi Ickowicz
Modified: 2016-02-10 18:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-30 16:07:11 UTC
oVirt Team: Storage


Attachments (Terms of Use)

Description Gadi Ickowicz 2014-01-30 15:35:48 UTC
Description of problem:
When removing a datacenter after setting the last domain to maintenance, DisconnectStorageServer is sent to hosts *before* DisconnectStoragePool. 

Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.2.master.20140112020439.git9ad8529.el6.noarch

2014-01-30 15:27:32,677 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.DestroyStoragePoolVDSCommand] (org.ovirt.thread.pool-6-thread-25) [16beba9f] START, DestroyStoragePoolVDSCommand( storagePoolId = 36263611-a
<.....snip.........>
2014-01-30 15:28:04,561 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.DestroyStoragePoolVDSCommand] (org.ovirt.thread.pool-6-thread-25) [43035533] FINISH, DestroyStoragePoolVDSCommand, log id: 428e6195
2014-01-30 15:28:04,600 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (org.ovirt.thread.pool-6-thread-25) [43035533] START, DisconnectStorageServerVDSCommand(HostName = gold-v
2014-01-30 15:28:05,248 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (org.ovirt.thread.pool-6-thread-25) [43035533] FINISH, DisconnectStorageServerVDSCommand, return: {}, log
2014-01-30 15:28:05,257 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (org.ovirt.thread.pool-6-thread-25) [43035533] START, DisconnectStorageServerVDSCommand(HostName = gold-v
2014-01-30 15:28:05,943 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (org.ovirt.thread.pool-6-thread-25) [43035533] FINISH, DisconnectStorageServerVDSCommand, return: {}, log
2014-01-30 15:28:05,946 WARN  [org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil] (org.ovirt.thread.pool-6-thread-38) Executing a command: java.util.concurrent.FutureTask , but note that there are 1 tasks in t
2014-01-30 15:28:05,947 INFO  [org.ovirt.engine.core.bll.storage.DisconnectStoragePoolAsyncOperation] (org.ovirt.thread.pool-6-thread-24) [43035533] Disconnect storage pool treatment vds: gold-vdsc.qa.lab.tlv.redh
2014-01-30 15:28:05,948 INFO  [org.ovirt.engine.core.bll.storage.DisconnectStoragePoolAsyncOperation] (org.ovirt.thread.pool-6-thread-38) [43035533] Disconnect storage pool treatment vds: gold-vdsd.qa.lab.tlv.redh
2014-01-30 15:28:05,950 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStoragePoolVDSCommand] (org.ovirt.thread.pool-6-thread-38) [43035533] START, DisconnectStoragePoolVDSCommand(HostName = gold-vdsd.
2014-01-30 15:28:05,952 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStoragePoolVDSCommand] (org.ovirt.thread.pool-6-thread-24) [43035533] START, DisconnectStoragePoolVDSCommand(HostName = gold-vdsc.
2014-01-30 15:28:05,954 WARN  [org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil] (org.ovirt.thread.pool-6-thread-4) Executing a command: java.util.concurrent.FutureTask , but note that there are 1 tasks in th
2014-01-30 15:28:05,962 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStoragePoolVDSCommand] (org.ovirt.thread.pool-6-thread-24) [43035533] FINISH, DisconnectStoragePoolVDSCommand, log id: 7c02bd99
2014-01-30 15:28:07,674 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStoragePoolVDSCommand] (org.ovirt.thread.pool-6-thread-38) [43035533] FINISH, DisconnectStoragePoolVDSCommand, log id: 17edc76a


How reproducible:
100%

Steps to Reproduce:
DC with 2 hosts, 1 domain
1. Move domain to maintenance
2. Remove datacenter
3. Check engine logs to see flow:

Actual results:
DisconnectStoragePool is sent to HSM host after DisconnectStorageServer

Expected results:
A host cannot disconnect from the pool if it is not connected to the storage server

Additional info:

Comment 1 Aharon Canan 2014-01-30 16:07:11 UTC

*** This bug has been marked as a duplicate of bug 1059769 ***


Note You need to log in before you can comment on or make changes to this bug.