Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059749 - rwtab files with trailing - no longer mounted tmpfs
Summary: rwtab files with trailing - no longer mounted tmpfs
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukáš Nykrýn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 14:44 UTC by Marcus Moeller
Modified: 2014-04-16 11:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-16 11:51:36 UTC


Attachments (Terms of Use)
patch to address the problem (deleted)
2014-02-18 11:56 UTC, Marcus Moeller
no flags Details | Diff

Description Marcus Moeller 2014-01-30 14:44:59 UTC
When I add a file with a trailing - (like /etc/passwd-) to rwtab, it is no longer mounted to tmpfs.

This worked fine on Fedora 19, but does no longer on Fedora 20 with:

initscripts-9.51-1

Comment 1 Marcus Moeller 2014-01-30 14:57:38 UTC
systemd.mount seems to use - as path delimiter. On files which contains - within the filename these are replaced by \x2d. But adding e.g. /etc/passwd\x2d did not help.

Comment 2 Marcus Moeller 2014-02-18 11:06:12 UTC
It still worked till initscripts.x86_64 0:9.50-1.fc20 so it must have been introduced in the latest changeset. Maybe with this one:

- readonly-root: bind-mount only necessary subset of entries in rwtab

Comment 3 Marcus Moeller 2014-02-18 11:56:20 UTC
Created attachment 864497 [details]
patch to address the problem

do not check for possible duplicates on files, but for directories.

Comment 4 Marcus Moeller 2014-04-07 07:11:26 UTC
Is there any update on that? @Lukáš could you please integrate the above patch?

Comment 5 Václav Pavlín 2014-04-16 11:51:36 UTC
Hi Marcus, thanks, it's fixed in upstream now - https://git.fedorahosted.org/cgit/initscripts.git/commit/?id=32e8cbc1c91ada764ef4b5bb817b0c045d3fb3a4


Note You need to log in before you can comment on or make changes to this bug.