Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059738 - postgrey failed to start, postgrey.service operation timed out
Summary: postgrey failed to start, postgrey.service operation timed out
Keywords:
Status: CLOSED DUPLICATE of bug 1058654
Alias: None
Product: Fedora
Classification: Fedora
Component: postgrey
Version: 20
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 14:14 UTC by Vladislav Grigoryev
Modified: 2014-02-03 01:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-03 01:37:23 UTC


Attachments (Terms of Use)

Description Vladislav Grigoryev 2014-01-30 14:14:47 UTC
Description of problem:
postgrey failed to start.
postgrey.service operation timed out.

Version-Release number of selected component (if applicable):
f20 minimal installation.
postgrey-1.34-11.fc20.noarch

How reproducible:
Always.

Steps to Reproduce:
1. yum install postgrey
2. systemctl start postgrey.service

Actual results:
systemd[1]: Starting Postfix Greylisting Service...
postgrey[14169]: 2014/01/30-17:59:12 postgrey (type Net::Server::Multiplex) starting! pid(14169)
postgrey[14169]: Binding to UNIX socket file "/var/spool/postfix/postgrey/socket"
postgrey[14169]: Setting gid to "695 695"
postgrey[14169]: Setting uid to "695"
systemd[1]: postgrey.service operation timed out. Terminating.
postgrey[14169]: 2014/01/30-17:59:17 Server closing!
systemd[1]: Failed to start Postfix Greylisting Service.
systemd[1]: Unit postgrey.service entered failed state.
systemd[1]: postgrey.service holdoff time over, scheduling restart.
systemd[1]: Stopping Postfix Greylisting Service...

Additional info:
Regression after migration from f19 to f20.

Comment 1 Christopher Meng 2014-01-30 15:48:14 UTC
Could you remove these lines in the service file cumulatively/independently and try again? 

--pidfile=/var/run/postgrey.pid \

--group=postgrey \ --user=postgrey \

I've received many similar bug reports recently, hope you can help and feedback some cases.

Comment 2 Vladislav Grigoryev 2014-01-30 18:39:52 UTC
Removing this one
>  --greylist-text="Greylisted for %%s seconds" \
resolves the issue.

cp -f {/usr/lib,/etc}/systemd/system/postgrey.service
sed -i '/--greylist-text=/d' /etc/systemd/system/postgrey.service
systemctl daemon-reload
systemctl start postgrey.service

Comment 3 Christopher Meng 2014-02-03 01:37:23 UTC

*** This bug has been marked as a duplicate of bug 1058654 ***


Note You need to log in before you can comment on or make changes to this bug.