Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059705 - Error when adding sub component of the same name in a different component
Summary: Error when adding sub component of the same name in a different component
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Administration
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
urgent vote
Target Milestone: ---
Assignee: Simon Green
QA Contact: Matt Tyson 🤬
URL:
Whiteboard:
Depends On:
Blocks: 578256
TreeView+ depends on / blocked
 
Reported: 2014-01-30 12:41 UTC by Jan Blazek
Modified: 2014-10-12 22:52 UTC (History)
5 users (show)

Fixed In Version: 4.4.2014
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-03 01:00:45 UTC


Attachments (Terms of Use)

Description Jan Blazek 2014-01-30 12:41:32 UTC
Description of problem:
I wanted to test the setup of kernel sub components at first on partner-bugzilla before we will add them to real bugzilla. I have found a problem there. I can't delete and then add sub component of the same name.

Version-Release number of selected component (if applicable):
partner-bugzilla.redhat.com version 4.4.1013

How reproducible:
I have deleted USB sub component in
product: Red Hat Enterprise Linux 6
component: kernel
and wanted to add new USB sub component under Desktop sub component.

Actual results:
After submitting the form, Bugzilla throws this error:
The sub component 'USB' already exists for the '' component with the same parent.

Expected results:
The sub component will be created.

Comment 1 Jason McDonald 2014-01-31 02:55:55 UTC
I am not able to reproduce this issue with the information given.

I started with:

Product: A
+--Component: B
   +--Subcomponent: C
   +--Subcomponent: D
   +--Subcomponent: E

and tried to change it to:

Product: A
+--Component: B
   +--Subcomponent: C
   |  +--Subcomponent: D
   +--Subcomponent: E

...by deleting Subcomponent D from Component B and then recreating Subcomponent D under Subcomponent C.

Please verify that this matches what you were trying to do, or alternatively please provide step-by-step instructions to reproduce the issue and the relevant part of the component/subcomponent tree as it stands at the beginning of those steps.

Comment 2 Jan Blazek 2014-02-04 13:50:43 UTC
This was exactly what I did.

Maybe the problem is something else. I just can't create sub component USB under sub component Desktop.

Product: Red Hat Enterprise Linux 6
+--Component: kernel
   +--Subcomponent: Desktop
      +--Subcomponent: USB

Comment 3 Alasdair Kergon 2014-02-12 00:44:39 UTC
I wrote a quick script to clone my 22 lvm2 subcomponents from RHEL7 across to RHEL6 and RHEL5.

This fails with the same error, both on partner-bugzilla and the live system.  It seems to give the error when adding a RHEL6 subcomponent that has the same name as a RHEL7 one i.e. neglecting to notice it's OK because the product is different.

Comment 4 Simon Green 2014-02-12 00:53:07 UTC
I can confirm this. Will get it into sprint14.

Comment 5 Simon Green 2014-02-12 01:43:33 UTC
Also fixed the error message so the component name is actually displayed.

Comment 8 Matt Tyson 🤬 2014-03-03 01:00:45 UTC
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.