Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059672 - usb_modeswitch-data-20150115 is available
Summary: usb_modeswitch-data-20150115 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: usb_modeswitch-data
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Huzaifa S. Sidhpurwala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 10:38 UTC by Upstream Release Monitoring
Modified: 2015-02-23 08:03 UTC (History)
4 users (show)

Fixed In Version: usb_modeswitch-data-20150115-1.fc21
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-23 08:03:57 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2014-01-30 10:38:27 UTC
Latest upstream release: 20140129
Current version/release in Fedora Rawhide: 20130807-1.fc20
URL: http://www.draisberghof.de/usb_modeswitch/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Account closed by the user 2014-01-30 21:07:29 UTC
Changelog:

20140129:
    Minor bug fix in configs 19d2:0149 and 19d2:2000 (Lars Melin reported)
20140128:
    ATTENTION: requires usb-modeswitch version >= 2.1.0 due to new para-
    meter StandardEject (further reducing config file size);
    Added devices: ZTE MF823/K5008-z, ZE-3G HSPA modem, four new Huawei/
    Vodafone devices (yet unnamed Kxxxx); thanks to Lars Melin for compiling

Comment 2 Upstream Release Monitoring 2014-03-30 11:18:01 UTC
Latest upstream release: 20140327
Current version/release in Fedora Rawhide: 20130807-1.fc20
URL: http://www.draisberghof.de/usb_modeswitch/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 3 Account closed by the user 2014-03-30 11:27:33 UTC
(In reply to Upstream Release Monitoring from comment #2)

> Latest upstream release: 20140327
> Current version/release in Fedora Rawhide: 20130807-1.fc20

Changelog:

20140327:
    Plenty of Huawei and ZTE devices added, several target IDs added (thanks
    to Lars Melin for the compilation); fix for Option GI1515 (0af0:d001) to
    be used with usb-modeswitch >= 2.1.1; unified switching message for
    nearly all Huawei devices
20140129:
    Minor bug fix in configs 19d2:0149 and 19d2:2000 (Lars Melin reported)
20140128:
    ATTENTION: requires usb-modeswitch version >= 2.1.0 due to new para-
    meter StandardEject (further reducing config file size);
    Added devices: ZTE MF823/K5008-z, ZE-3G HSPA modem, four new Huawei/
    Vodafone devices (yet unnamed Kxxxx); thanks to Lars Melin for compiling
20131113: ... (in Fedora)


ping!

Comment 4 Account closed by the user 2014-04-24 14:38:24 UTC
(In reply to Xose Vazquez Perez from comment #3)
> (In reply to Upstream Release Monitoring from comment #2)
> 
> > Latest upstream release: 20140327
> > Current version/release in Fedora Rawhide: 20130807-1.fc20

> ping!

DONE: http://koji.fedoraproject.org/koji/buildinfo?buildID=511318

-thanks-

Comment 5 Upstream Release Monitoring 2014-05-30 14:39:17 UTC
Latest upstream release: 20140529
Current version/release in Fedora Rawhide: 20140327-1.fc21
URL: http://www.draisberghof.de/usb_modeswitch/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 6 Onyeibo Oku 2014-07-05 02:24:19 UTC
*bumping* this report

I just filed a corresponding upgrade report for usb_modeswitch.  I hope it not a duplicate of an existing report. See: https://bugzilla.redhat.com/show_bug.cgi?id=1116484

Comment 7 Account closed by the user 2014-08-13 14:19:59 UTC
(In reply to Upstream Release Monitoring from comment #5)

> Latest upstream release: 20140529
> Current version/release in Fedora Rawhide: 20140327-1.fc21

http://www.draisberghof.de/usb_modeswitch/ChangeLogData

20140529:
    ATTENTION: requires usb-modeswitch version >= 2.2.0 due to new para-
    meter HuaweiNewMode (further reducing config file size);
    Added devices: Nexperia TM TD-SCDMA, Sunplus SU-3200U, Olivetti
    Olicard 160 and Olicard 500, Ericsson F5521gw, Sony Ericsson EC400,
    Huawei E180, Huawei/Vod. W5101 Router, Huawei E3531, Huawei E3131
    (Variant), Novatel MiFi 4082, Emobile D21LC, Prolink PCM100, Titan 3.5G,
    several nameless ZTE modems, several minor device configuration
    corrections (thanks once again to Lars Melin for the tedious device
    research and compilation!);
    Substantial change in handling of Huawei devices - generic udev rule and
    additional generic configuration files (as fallback for unknown models
    or as OS-specific catch-all); see README for details

Comment 8 Bernhard Reiter 2014-10-23 23:25:03 UTC
*ping*

Please update to 20140529 -- it's almost 5 months old and brings a lot of devices currently used by many network operators!

Comment 9 Account closed by the user 2014-10-28 16:04:41 UTC
BTW, device_reference.txt should be moved from usb_modeswitch to usb_modeswitch-data. 

And it should be updated from http://www.draisberghof.de/usb_modeswitch/device_reference.txt

Comment 10 Bernhard Reiter 2014-11-24 12:53:49 UTC
Hm, still no reaction from the maintainer. Can someone else among us subscribers update this package? Doesn't seem to be awfully complicated. (Why am I not doing it myself, then? Because I'm not a Fedora dev, I don't even run Fedora -- I'm posting here on behalf of a less technical Fedora user.)

Comment 11 Huzaifa S. Sidhpurwala 2014-11-24 13:56:29 UTC
(In reply to Bernhard Reiter from comment #10)
> Hm, still no reaction from the maintainer. Can someone else among us
> subscribers update this package? Doesn't seem to be awfully complicated.
> (Why am I not doing it myself, then? Because I'm not a Fedora dev, I don't
> even run Fedora -- I'm posting here on behalf of a less technical Fedora
> user.)

Hi Bernhard,

I can try and get this done this week, sorry for the delay.

Comment 12 Bernhard Reiter 2014-11-24 13:58:29 UTC
Hi Huizafa,

that would be awesome, thank you! (And sorry for nagging ;-) )

Comment 13 Account closed by the user 2015-01-06 00:36:04 UTC
(In reply to Upstream Release Monitoring from comment #5)

> Latest upstream release: 20140529
> Current version/release in Fedora Rawhide: 20140327-1.fc21
> URL: http://www.draisberghof.de/usb_modeswitch/

DONE: http://koji.fedoraproject.org/koji/buildinfo?buildID=595281

Comment 14 Upstream Release Monitoring 2015-01-19 10:48:52 UTC
Latest upstream release: 20150115
Current version/release in Fedora Rawhide: 20140529-1.fc22
URL: http://www.draisberghof.de/usb_modeswitch/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring Soon this service will be implemented by a new system: https://release-monitoring.org/
It will require to manage monitored projects via a new web interface. Please make yourself familiar with the new system to ease the transition.

Comment 15 Account closed by the user 2015-01-19 15:10:23 UTC
(In reply to Upstream Release Monitoring from comment #14)

> Latest upstream release: 20150115
> Current version/release in Fedora Rawhide: 20140529-1.fc22
> URL: http://www.draisberghof.de/usb_modeswitch/

20150115:
    Added devices: Aiko 81D, Alcatel-Lucent ABS-T920, Alcatel X602D,
    Amoi H-01, Amoi H-02, D-Link DWM-157 B1, D-Link DWM-221, D-Link
    DWM-156 A8, D-Link DWM-167 A1, Huawei ETS1201, Intex 3.5G, Intex Speed
    3G v7.2, Linktop LW272/LW273 (BSNL Teracom), Onda MV815U, Onda MO835UP,
    Onda MDC655, Onda MDC655 Variant, Quanta MU-Q101, StrongRising STD808,
    Telewell TW-LTE 4G, TechFaith Venus VT-18, TechFaith BSNL Capitel,
    TechFaith FlyingLARK46, Tlaytech TEU800, TU930, IVIO IV-2010u, Viettel
    VT100, Wisue W340, Zoom 3G, ZTE / Vodafone K4607-Z, ZTE / Vodafone K4201,
    ZTE MF730, ZTE MF710M Variants, several modems with unknown names (vendor
    ID 0x257a); many minor corrections and additions to existing
    configurations. Thanks to Lars Melin once more for extended research and
    collecting!

Comment 16 Account closed by the user 2015-01-28 11:14:06 UTC
Could you please update Fedora 21 to 20150115 ?

There are a lot of new devices supported since usb_modeswitch-data-20140327-2.fc21 

-thanks-

Comment 17 Account closed by the user 2015-02-13 17:39:05 UTC
(In reply to Xose Vazquez Perez from comment #16)

> Could you please update Fedora 21 to 20150115 ?
> 
> There are a lot of new devices supported since
> usb_modeswitch-data-20140327-2.fc21 
> 
> -thanks-

ping! anyone?

Comment 18 Fedora Update System 2015-02-13 22:27:07 UTC
usb_modeswitch-data-20150115-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/usb_modeswitch-data-20150115-1.fc21

Comment 19 Account closed by the user 2015-02-13 22:37:16 UTC
As usb_modeswitch-data changelog says:

20140529:
    ATTENTION: requires usb-modeswitch version >= 2.2.0 due to new para-
    meter HuaweiNewMode (further reducing config file size);

It's needed latest release of "usb-modeswitch"

Comment 20 Account closed by the user 2015-02-13 22:40:32 UTC
(In reply to Xose Vazquez Perez from comment #19)
> As usb_modeswitch-data changelog says:
> 
> 20140529:
>     ATTENTION: requires usb-modeswitch version >= 2.2.0 due to new para-
>     meter HuaweiNewMode (further reducing config file size);
> 
> It's needed latest release of "usb-modeswitch"


bug #1059671

Comment 21 Fedora Update System 2015-02-15 03:22:35 UTC
Package usb_modeswitch-data-20150115-1.fc21, usb_modeswitch-2.2.0-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing usb_modeswitch-data-20150115-1.fc21 usb_modeswitch-2.2.0-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2039/usb_modeswitch-2.2.0-2.fc21,usb_modeswitch-data-20150115-1.fc21
then log in and leave karma (feedback).

Comment 22 Fedora Update System 2015-02-23 08:03:57 UTC
usb_modeswitch-data-20150115-1.fc21, usb_modeswitch-2.2.0-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.