Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059658 - network time not working when ntpd service down
Summary: network time not working when ntpd service down
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: chrony
Version: 7.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 10:16 UTC by Vladimir Benes
Modified: 2015-08-03 11:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-03 11:49:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vladimir Benes 2014-01-30 10:16:37 UTC
Description of problem:
While I have ntpd service stopped I can juggle with network time toggle for ages without any effect. Shouldn't this toggle enable ntpd as well? At least there should be some hint over the button saying that.

Version-Release number of selected component (if applicable):
control-center-3.8.6-7.el7.x86_64
ntp-4.2.6p5-16.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.stop ntpd service
2.go to control-center date & time panel
 2.1 move time a bit backward
3.unlock and enable network time


Actual results:
time is not changed back to correct one

Expected results:
ntpd should be started and enabled for future start as well

Additional info:

Comment 1 Vladimir Benes 2014-01-30 15:20:50 UTC
this seems like not doing anything at all,
I can turn it to off, restart service and time is synced again. So after reboot time will get synced anyway. This should stop service and disable it if set to off.

Comment 2 Vladimir Benes 2014-02-05 13:07:55 UTC
even if time is incorrect, ntpd service started I can see no ntp time correction when ntp is enabled. This should be fixed too.

Comment 3 RHEL Product and Program Management 2014-03-22 06:07:51 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 Bastien Nocera 2015-04-07 10:58:21 UTC
(In reply to Vladimir Benes from comment #2)
> even if time is incorrect, ntpd service started I can see no ntp time
> correction when ntp is enabled. This should be fixed too.

In which case the problem is with ntpd.

Comment 6 Miroslav Lichvar 2015-04-07 11:07:27 UTC
So enabling the checkbox in control-center enables and starts ntpd, but ntpd doesn't correct the clock? Can you please post "ntpq -pn" output when ntpd has been running for couple minutes?

Comment 8 Vladimir Benes 2015-08-03 11:49:48 UTC
new 3.14 control-center works as expected, automatic date and time enables/starts chronyd.service and tunes time and date if incorrect.


Note You need to log in before you can comment on or make changes to this bug.