Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059651 - include analyze_VMcore event in RHEL VMCore workflow
Summary: include analyze_VMcore event in RHEL VMCore workflow
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreport
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Šplíchal
QA Contact: Adam Kolář
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 10:04 UTC by Jakub Filak
Modified: 2016-12-01 00:44 UTC (History)
4 users (show)

Fixed In Version: libreport-2.1.11-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 13:15:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jakub Filak 2014-01-30 10:04:39 UTC
Description of problem:

/usr/share/libreport/workflows/workflow_RHELvmcore.xml

(it is in libreport-rhel package)

may need the addition of <event>analyze_VMcore</event> for crashing MCE's to be processed properly.

Bug # comment #2 Denys Vlasenko 2013-11-25 15:19:52 CET


commit 34e02b63d3f8cec25cc5797a592ba9048f90505f
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Wed Nov 27 13:14:24 2013 +0100

    workflow_RHELvmcore: run analyze_VMcore too
    
    analyze_VMcore does the following:
    
    * extracts oops from vmcore-dmesg.txt
      (or from vmcore, if vmcore-dmesg.txt is missing);
      creates "kernel" element.
    * generates dedup hashes.
    * generates pkg_* elements.
    
    These steps probably aren't necessary if we take the usual step
    of running report_RHTSupport: RHTSupport people don't absolutely
    need that data. (However, I did not test whether report_RHTSupport
    actually works w/o analyze_VMcore).
    
    But for Machine Check Exceptions, oops extraction is crucial:
    without seeing "backtrace" element, which in this case shows
    MCE message, user won't realize he has a hardware issue,
    and will still contact RHTSupport, only to be told by them,
    after analysis, "look at your CPU/RAM, they seem to be faulty"
    - exactly the scenario we want to avoid (we want user
    to not waste his and RHTSupport's time - the problem is known).
    
    Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>

diff --git a/src/workflows/workflow_RHELvmcore.xml.in b/src/workflows/workflow_RHELvmcore.xml.in
index 31712e0..4dbfc00 100644
--- a/src/workflows/workflow_RHELvmcore.xml.in
+++ b/src/workflows/workflow_RHELvmcore.xml.in
@@ -5,6 +5,7 @@
 
     <events>
         <event>collect_*</event>
+        <event>analyze_VMcore</event>
         <event>report_RHTSupport</event>
     </events>
 </workflow>

Comment 6 Ludek Smid 2014-06-13 13:15:19 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.