Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 105961 - Add hardware in netwrok configurations results in crash
Summary: Add hardware in netwrok configurations results in crash
Keywords:
Status: CLOSED DUPLICATE of bug 76226
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-30 00:05 UTC by Ralf Cozzi
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:51 UTC


Attachments (Terms of Use)

Description Ralf Cozzi 2003-09-30 00:05:50 UTC
Description of problem:

In network configuration, add hardware crashes

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select network config, click hardware, click add, choose ethernet, crash!
2.
3.
    
Actual results:


Expected results:


Additional info:

Please visit http://bugzilla.redhat.com/bugzilla/ !
File a bug against component redhat-config-network. Thank you!

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1239, in on_hardwareAddButton_clicked
    self.showHardwareDialog(type, false)
  File "/usr/sbin/neat", line 1269, in showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 75, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 135, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Comment 1 Harald Hoyer 2003-10-24 16:03:24 UTC

*** This bug has been marked as a duplicate of 76226 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.